Bluetooth Problem Elite Qubo


(Christian Dinraths) #1

Hello,

I have a problem to connect my Elite Qubo Power Fluid Trainer with Zwift. I use the Elite Bluetooth Smart Sensor for Speed and cadence. I am able to connect my android phone with my computer by using the mobile link app.

Unfortunately Zwift can’t get connected with my trainer. When i search “speed sensor + classic trainer” nothing appears. Eventough i start pedaling.

Does anyone else have the same problem?


(Paul Allen) #2

Have you tried pairing it as a Power Sourse, I believe it is a supported trainer.


(Christian Dinraths) #3

Yes i tried both. I am sure that the bluetooth sensor is working, because my elite app gets all information…


(Paul Allen) #4

Disconnect it from the Elite app (and any other devices), BLE can only be connected to one device at a time.


(Christian Dinraths) #5

I have done it also. Nevertheless Zwift can’t find any trainer…


(Paul Allen) #6

Is the firmware up to date?

Also, try logging out of the app, closing the app and logging back in to it. This will clear the app’s cache and might help you out.


(Krystian Kisza) #7

Hi i have the same problem with Elitę Qubo Digital Smart B+. Myelite app works fine on android phone via BLE. Zwift connects normally on iPad Air via BLE (but gives much lower power readout meaning i am pedalling hard and I bearly move forward in game) But I am not able to connect trainer via Zwift mobile link with pc with W10 on it. Tried all tips from above posts, nothing works.


(brent Lacey) #8

Having had the exact same problem I believe the problem is difficult to solve, hence why this issue still exists 5+ months after it was first reported.

As the issue I believe may be caused by not just the hardware or just the software but a combination of the two…

While switching to ant+ will solve everyones problems as mentioned it would be real nice for all of us who have purchased zwift and these smart trainers, that the device works out of the box (without the need to purchase additional addons like ant+)

To properly troubleshoot the problem I tried the following connection types with Zwift:

-Android Marshmallow phone with the mobile link app will detect all other bluetooth sensors but not the power sensor.

-Android Marshmallow phone with myetrainer app will detect all other bluetooth sensors but not the power sensor. The power sensor is detectable by Ant+ via the android native support however.

-Iphone 4 via bluetooth and the mobile link app the power sensor can be read along with the other sensors.

-Iphone 4 with the myetrainer app via bluetooth the power sensor can be read along with the other sensors.

-An Android marshmallow phone with mobile link app and Ant + connection  the sensors connected to the PC via ant+ are working perfectly ( a fix but not the solution! ).

My read of the "Possible’ Cause:

I believe the issue may be because the Android has support for the ant+ standard, whereas this protocol is not supported by iphones. As Ant+ is on by default, the signal from an android device may be able to be being detected by the qubo as the first thing it reads.

I heard a rumour from other users that the Qubo has a firmware issue that it has a tendency to pair to the first wireless protocol it detects and then gets stuck in that mode from then on (ie ignoring the bluetooth signal).

Being that android phone unlike all Iphones support the ant+ protocol, for those users with the mytrainer app installed, if this is used first then the qubo detects the ant+ power signal and then fails to detect the bluetooth signal from then on.

This hardware fault when combined with the use of the zwift mobile link app which can only detect bluetooth signals (on both android and iphones) then of course fails to be able to detect the power signal.

Outcome:

The zwift application fails to pair to the smart trainer via the zwift mobile link, because the qubo is no longer listening for the bluetooth standard to connect too it, which is where all of the non ant+ users are stuck.

Both suppliers are slightly pointing the finger at the other to solve this issue, (This is exactly where my support enquiries were left by both teams)

So I would hope the teams could communicate a bit further on the above and resolve this once and for all on these forums! Thanking you. 


(Krystian Kisza) #9

Unfortunately the best solution at the moment is to get a ANT+ dongle. From my experience the cheapest ones for 5-10GBP/EURO from amazon work fine with the mentioned Qubo. 


(Joe Scuderia-Longo) #10

Same problem - The Elite trainer worked impeccably for the first 2 weeks, connecting over BT or ANT+ on my laptop, and over BT to my cell phone.

Indeed: I have connected to Zwift on the laptop over ANT+ and simultaneously to the Elite iPhone app over BT. I did that several times to compare Swift’s reading’s to the Elite’s (Elite is far more accurate).

Then yesterday it all stopped working. The iPhone connects some of the time, but not twice in a row. I remove the battery from the Misuro B+ unit, re-insert, and it connects to Zwift over BT, but no over ANT+.

I’ve tried inserting new batteries twice. I’ve also pressed the tiny switch to set the Misuro to my Elite model, as directed in the instructions. Still no luck. I’ll keep experimenting. Hoping someone here has more input.

  • Joe

(Forrest Kieser (Team ZF)) #11

I am having this same issue and I was advised by Jason K. that there was only one other user with this issue and that it may be specific to my phone that I am using to link with bluetooth and only with Elite trainers.  He also advised that they would continue looking into the issue but it would take some time to figure it out as they are a small group and are working on expanding Zwift.

So in the interest of figuring this out so that we can all connect by bluetooth as we were all sold on, I am using a Samsung Galaxy S6 with Android version 6.0.1.  I am running Zwift on a Lenovo Yoga 14 Thinkpad running Windows 10.  Finally, I am using an Elite Qubo Digital Smart B+ trainer.

Using bluetooth I see my Polar H7 heartrate monitor and Polar cadence sensor.  I can see QD in the list of bluetooth devices in my cell phone and in controllable trainers but it will not appear in the Power setting.  In fact, nothing appears in the power setting.  I can see several other Elite trainers in the dumb trainer listings but not the Elite Qubo Digital Smart B+ which I would not expect to find anyway.

 Connecting by ANT+ I can connect to the FE-C trainer in the power setting and in the controllable trainer.  The issue that I keep having is that when I then go to connect my Polar H7 and cadence sensor, the ANT+ stops working.  I have to keep unplugging the ANT+ and restarting everything until it all hooks up and works as expected.  Once connected I was to state that it works without issue during the time I am riding.  The problem is that I keep having to go through this same process every time I ride.  I have tried to do several races but because I can’t get connected in time I have missed them.  REALLY, REALLY getting frustrated by it all.  Llama and DC really sold me on this one!