Bluetooth LE (BLE) Feedback

(Cleve) #161

Others may have reported this already.

Wahoo Blue Heart Rate.  Windows 10.  iPhone 6S

Phone app must be running and be “on screen” and not in the background.  Then launch Zwift.  Will not connect with reverse order. 

If I have to leave the trainer room after connecting, I carry the phone with me.

0 Likes

(Pete Bynon ) #162

ios/El Capitan/Updated BLE App --Seems to be working LOTS better than before. A few dropouts here and there, but only for a second or so. I guess I’ll continue with Zwift!

0 Likes

(Chris Jefferies) #163

After  A** lan Henderson **comment about WIFI we put in an extender and had some improvement.   Since then we’ve removed the extender and put in another WIFI router on the same house network in our Zwift room.

This seems to have fixed the problem.  My son rode the new mountain course (wow!) this evening and it never failed in over an hour.  That is the first time since he got the sensors at Christmas that it’s worked perfectly :slight_smile:

So it seems for us,  it’s not the bluetooth but the quality of the WIFI the phone connects too that is the issue.

Now we just need to get his Polar H7 heart rate strap working,  Zwift can’t see that at all at the moment. 

0 Likes

(system) #164

Hi Chris –

We ordered a Polar H7 for the office here and it seems like it is working for us. We have a new version (1.6.1) of  Zwift Mobile Link for iOS out now that has BLE improvements, and there will be an Android 1.6.1 with BLE improvements in a couple of days.  Hopefully those will help.

 

Alarik

 

0 Likes

(Georg Nikodym ZHR (E)) #165

FWIW

Did a quick 40ish minute ride yesterday with 1.6.1 of the iOS app and both my no-name BT cadence and polar h7 hr strap stayed connected for the whole thing.

A definite improvement from previous rides where I’d have one or the other but rarely both (and sometimes none by the end of a ride).

0 Likes

(Brian Thomas) #166

A couple times now I have had disconnects during a ride.  To get Zwift to read power again, I had to force quit the app on my phone and re-pair in the settings menu.

However, when I get back in the game, the trainer is still stuck on the same resistance.  Even restarting my phone and the trainer does not fix this.  I am forced to end my ride and restart Zwift.

There are few things that would help:

1: Fix the issue with disconnects.

2: Fix the issue with the smart trainer functionality not restoring when re-pairing.

3: Make it possible to resume rides after restarting Zwift. It’s really frustrating to be near the top of the mountain and have to start over.

 

My setup:

Kickr Snap

Nexus 6p connected to the Kickr

0 Likes

(Cleve) #167

My Wahoo Blue HRM would not connect today. I rebooted my computer, started Zwift several times, even disconnected and reconnected the Wahoo Snap.  I also tried resetting the HRM by removing the battery, shorting the electrodes and then re-inserting. The battery is pretty new. None of the above worked.

0 Likes

(Mark G) #168

Yesterday I made my first testride on Zwift. It felt really like fun to do. I’m hoping that the problems I met will be fixed soon.

My problems:

  1. The connection of the sensor dropped often so the speed reduced to 0. This happend while the screen of the phone was still on and the app-screen was visible.

  2. The OSX app crashed quite a few times, having the rainbow-mouse-icon.

  3. Further on the translation of the speed was totally unrealistic. It claimed I was doing 17.9 watts / kg. The maximum of the watts is reached immediately (1200 watts). The translation of the sensor (Misuro B+) is definitely not correct, I see others making that claim also with the Ant+ protocol.

Elite has a specific translation for Misuro B+ setups on the Turbo Muin.

Turbo Muin (serial from 10470 to 30000): wheel circumference
Turbo Muin / Turbo Muin Smart B+ (serial from 30001): wheel circumference/13,2.

Something that’s come to mind just now: I will make the setup like Smart B+ to force another speed-translation. That might just work for the right translation! 

My setup: 

  • Elite Turbo Muin (30001+)
  • Misuro B+ (BLE)
  • iPhone 6 (iOS 9.3.1) with Zwift Mobile Link 1.6.1 (169) - screen always turned on
  • MacBook Pro 13" - OSX El Capitan 10.11.3
0 Likes

(James Dunnigan) #169

I haven’t been able to get very far my macbook and or iMac wouldn’t connect to the iPhone.  Any tips seems like everyone got past this stage easily

0 Likes

(Oliver Leach (RPR)) #170

Stages 105 5800 G2 (firmware up to date)
Polar H7 HRM
Panobike speed/cadence sensor

Samsung Galaxy Tab S2 - Android Lollipop
Windows 8.1 64-bit
Zwift Mobile Link app 1.6.2 (181)

I tried to use the bluetooth for the first time on Monday. Initially it all worked and everything connected through to Zwift. Unfortunately the connections dropped permanently after 7 minutes. After rebooting computer and reloading Zwift I managed another 12 minutes before the app crashed.

I have always found the mobile link app crashes after a few minutes. This was on a Moto G running kitkat, a Nexus 7 running kitkat, and now a brand new Samsung Galaxy Tab. In fact I’ve never had the app last the entire training session.

After that latest crash the app won’t recognise any of my Bluetooth sensors whatsoever. I switched back to ANT+ for power only and that dropped out repeatedly yesterday necessitating a game reboot mid-ride.

All in all a mixed bag but the main issue seems to be instability in the Android app, at least running on my systems. I understand that the signal dropouts might improve if I can get bluetooth working as it locks on better and is less prone to interference than ANT+.

0 Likes

(alan henderson) #171

I’ve found during my last few rides BLE has been fairly stable and although my Watts do occasionally freeze (i.e not pedaling but the game still thinks I am so I continue to move) things are much more enjoyable.  I did find something new however which I thought was worth a quick share ---- 

After doing a time trial I was coasting down to a lower Wattage and noticed it dropped to zero and would not pick up again, rebooted the app, the phone, BLE, WIFI but no joy … so I dropped back to the Inride app (I use a Kinetic Road Machine) and did a quick re-calibration then jumped back to the Zwift app and found everything had reconnected.  Didn’t have to close down my ride so picked up from where I left off.

Not ideal, but it worked and was better then having to reboot everything and loose a ride part way through.

Alan

0 Likes

(Rene Tetter) #172

Hi Zwift, I was wondering if you could add the isc-11 on the Bluetooth pair-able list. Thanks! Once you do, I’ll finally be able to use your product. Also, I have a Blackburn tech mag. I’m not sure if it will work. Thanks again!

0 Likes

(Dan Smothers) #173

I currently have a windows 7 computer with zwift downloaded. I also have a GS4 with Bluetooth 4.0 connectivity, a Kurt Kinetic Smart trainer (inRide pod attached and detected by the Kurt Kinetic app), and a Wahoo Tickr Bluetooth and Ant+ HR monitor, I also have a Wahoo speed/cadence bluetooth/ant+ sensor on the way. 

I cannot get any of these devices to register with Zwift over bluetooth. I do not have an ant+ dongle, but I am skeptical about purchasing one given my experiences so far with Zwift. I’ve been able to register and calibrate my inRide pod with the KK app on my GS4 and go through workouts without problems. 

I also have the Wahoo fitness app on my phone and it detects the Wahoo Tickr without flaw. Zwift seems to be ignoring all of my devices and it is very frustrating. I was excited about using this software but it has been nothing but a waste of my time and energy so far. I could have had several workouts done by now, which is a huge pita to say the least. 

Any ideas here?

0 Likes

(Eric ) #174

Hi Dan,

Close all those apps on your phone. Unpair all of them from the Bluetooth screen. Start up the Zwift Mobile Link and Zwift on your computer.

If any of those apps are open (InRide, Wahoo), they take control of your Bluetooth device and DO NOT pass the signal on to Zwift.

0 Likes

(Dan Smothers) #175

Still no dice on the bluetooth connectivity. Zwift is the only application out of all that I’ve tried that won’t detect the Wahoo Tickr or the Kurt Kinetic inRide. I’ve turned off all the applications, except for Zwift, and still nothing registered. I even uninstalled/reinstalled Zwift on both my GS4 phone and PC and it didn’t solve the problem. Also changed out the battery on the Kinetic inRide and nothing helped.

0 Likes

(Dan Smothers) #176

Also, I should note that the Zwift application has the blinking phone while loaded up on the PC but will not connect to any BT devices. Ordered a garmin ant+ dongle out of frustration that will be here on Friday, if this doesn’t work, it’s safe to say I’m over zwift. (The Wahoo Tickr and speed/cadence sensors are BT and Ant+ compatible)

0 Likes

(Dan Smothers) #177

Reformatted my hard drive and reinstalled a clean verified copy of Windows 7 and that didn’t help. Now upgrading to Windows 10 and trying it this way. Honestly, if Zwift shouldn’t roll out BT compatibility if it hasn’t made it ready for use.

0 Likes

(system) #178

Hi Dan –

The problem is not going to be with your Windows installation or with you Zwift installation on Windows.  The BLE connection is made by the Zwift Mobile Link app, because the mobile devices can all be pretty much counted on to have Bluetooth support these days.

If you open a support ticket, a member of our support staff can help you sort through your issues:

 

0 Likes

(Dan Smothers) #179

I wonder if it’s an Android problem then? I’ve tried to connect the bluetooth devices every way, and in every combination, for the past 36 hours and I’m on the edge right now lol. I already have a ticket up but haven’t been provided any solutions that worked.

0 Likes

(system) #180

Is the Android app paired with the game?  When the app pairs with the game, you will see a dashboard on the app which shows things like Watts, heart rate, etc.

Here is a little knowledge base article talking about pairing.  If the game and the app are not paired, you will not be able to use the app to pair via Bluetooth to your equipment.

0 Likes