Bluetooth LE (BLE) Feedback

(John Hampton) #61

Looking at the list of OS X machines, is BLE support coming for the actual application?  All macs released in the last few years have BLE support built in, which works great in trainerroad.  BLE dongles are available for PC’s that don’t have support (or older Mac’s).  The iOS app as a ‘relay’ is clunky.  Is support on the actual application itself coming?

 

 

(J Saldana-) #62

I cannot get the bluetooth to connect with Kinetic Inride. Pairing a windows surface tablet with Iphone 5s. Ant+ works fine.

(Chris O'Hearn) #63

I hadn’t realised this was rolled out until I forgot my Ant+ Dongle !

Tried it, followed the instructions and it worked perfectly.

Connected using P1 Powertap pedals, iPhone 6 to a 2011 MacBook Pro.

I also simultaneously connected a Mio Link HR monitor.

Rode for an hour and the power was a pretty consistent mirror of the data on my Garmin head unit.

Great stuff, thanks.

(Bill Verdon) #64

I was able to pair my KK inRide POD (Version 1 as well as Version 2) and it works fine. if you calibrate the POD via the KK inRide app, you must remember to disconnect the InRide in the app BEFORE you try to pair the device in zwift. 

It is still unclear to me whether or not the calibration stays with the POD when moving from the KK inRide app to zwift. Zwift tells me yes…KK tells me no. 

Who knows… 

Don’t ask me to open up a support ticket with zwift…already been down this path…I get no real straight answers. Opened tickets with both companies…you guys are clearly not communication with each other.  Pretty frustrating. Almost as frustrating as the little dance we have to do to get BLE to pair in zwift and the fact there is no Android support for BLE.  

(Jeff Wulf sub2) #65
  • ANDROID ANDROID ANDROID / WINDOWS WINDOWS WINDOWS

:slight_smile:  

(Eric ) #66

Hi Bill,

It stores its calibration on the POD itself, which Zwift can access. Not sure why KK is telling you differently.

The “dance” is to remind you that this, indeed, a Beta of Bluetooth compatibility. When it’s not in beta, I doubt you will need to enter in “BLEBETA” as a promo code:)

Jeff: As for Android and Windows - Android is coming soon. Windows should work already as it’s not dependent on OS X.

(Bill Verdon) #67

I appreciate that it is in Beta…and understand it will not be perfect. The dance I am referring to is the sequence of getting it to work. If you don’t follow the sequence, it won’t pair. 

Some people like to dance…just sayin’

 

 

(W Huphardid) #68

anyone have any tips for connecting KK InRide ?? I try the instructed protocols everyday hoping for a miracle but Zwift just cant find my device…

I have no idea why some would have success and I fail…besides I’m a top notch loser…

Running Win10 KK Rock and Roll Smart…iPhone6…yada yada…

InRide works great with Kinetic app…no issues…my PC will pair with InRide app…no problems…

just never can get a sequence where the KK InRide is picked up in the instruction sequence…

entering P for promo…works…

going A to find devices still shows no bluetooth connection

does the phone need paired with the PC ?

do I need to transmit bluetooth data from the phone to the PC ?

what magic are you wizards doing ? 

I want to ride with the cool crowd ! I demand satisfaction, um, please ?!?

(Stu Berry) #69

Hi, I had a lot of problems yesterday. It’s seems to pair to my phone without the promo code. I had to uninstall the game and reinstall, shut down the app on my phone. Then start the game, the app, pair them and then find my Inride sensors. Painful but rewarding once you arrive on the island… 

(W Huphardid) #70

how did you pair the app and the game ?

 

(W Huphardid) #71

reinstalled the program, still nothing, with the P or without…

seems like it’s not connecting to my phone…

where does inride show up on your phone ? 

is it a bluetooth device ? is it through the KK app ? 

i feel like I’m missing something basic…

the only place I see the inride sensor connecting to my phone is through the KK app…

i have no idea why nothing is pairing into Zwift…nada, not even recognizing my phone…

AAARRRgggghhhhhhhh…uuuuugggggggHHHHHH !!!

all I wanna do is ride with with some avatars through a virtual world while not really moving and waiting for my legs to fall off…is that asking too much ? 

win10, iphone 6, kk rock and roll smart inride 

(Pawel Mostowy CVR (C)) #72

Did you do everything as instructed? 

The game and the phone connect automatically under one condition that both are connected to the same WiFi network. The app on your phone must have Bluetooth option selected. When you start your ride on PC you should be able to see ride button in the phone app instead of peek button. You press that and than you should be able to pair the device in a game on PC.

 Also consider that blutooth sensors can be connected only to one app at the time so disconnect your sensor from other apps even if they are just in background or just completely close them in your iPhone.

I can’t say anything more than that. It should work.

 

 

(Stu Berry) #73

The sensors should only link to your computer in the game. Not via Bluetooth in the inride app or the zwift app. If this has happened you won’t get a match up in the game. I had this issue/ misunderstanding at the beginning. Like was said above in your zwift app settings the Bluetooth sensors switch needs to be on. It’s a bit tricky at times. Very tricky. They’re working on it. 

(W Huphardid) #74

i dont know, i never get my phone and PC to pair in Zwift…

peek never turns to ride…

bluetooth on, nothing connected, same wifi, good thing its a rest day…

thanks for all the advice…im still stuck with flat…

the sun will come out tomorrow, bet your bottom dollar that tomorrow, I might jump off a cliff…

 

(Bill Verdon) #75

Couple of notes that may (or may not) help:…

  • makes sure that your phone’s BT is enabled (duh…yeah I know) 
  • make sure that the BT sensor is enabled in the mobile link software
  • make sure that you are on the same network (wifi or LAN should work just as long as the are on the same IP segment and you don’t have security set up on any network gear to block broadcasts). 
  • If you have connected the inRide POD to your KK inRide app on your mobile device…you must DISCONNECT it before you move onto the zwift app otherwise this will never work. 

And of course you need to make sure you do things according to the order in this link:

https://support.zwift.com/hc/en-us/articles/206576683-Bluetooth-LE-BLE-Support-for-HR-Monitors-Power-Meters-and-Cadence-Speed-Sensors

Here’s the quick breakdown:

  • you should calibrate inRide on KK inRide app on your mobile device first! warm up those tires and the turbo- calibrate it! Once you do this…disconnect it from the KK app!  Close the KK inRide app. 
  • log into Zwift on IOS device 
  • enable sensors on IOS device
  • start zwift and log in
  • once you see the PAIRED DEVICES screen hit ESC. your dude should be there sitting…waiting to roll!
  • type in P for promo code…type BLEBETA 
  • Type A to get back to the PAIRED DEVICES screen
  • Under “Power Source” click on search…you should see the inRide device select it

I have both the POD ver 1 and 2 an either should work this way (although I can’t remember if when using the POD ver 1 it actually said inRide).

Zwift may have changed something for the ver 1 POD so I have not tested it since the latest support update for inRide. it does work with the new KK InRide POD ver 2

Honestly…this is too much crap to go through to test a beta feature in zwift or ANY system for that matter. If they want us to test this, stop making us go through this effort. I mean…seriously…if it is beta…we get it…just make it more seamless for the user so we can actually test the code for issues and not force us through this convoluted effort.  

 

 

 

 

(Stu Berry) #76

Tomorrow! I’ll be riding tomorrow if I do the dance moves right logging on… Good luck Todd! All I can say is it’s frustrating but totally worth the cha cha cha…

(J Saldana-) #77

I got finally got the zwift app to sink with phone. I followed the instructions noted from Pawe Mostowy above. Thanks for the help all.

(W Huphardid) #78

thanks again to the community…i solved the connection issue…

I run two wireless networks in house…one router is 12 years old, the other is two years old…Comcast ‘standard issue’ routers…

every so often I run across a service that doesn’t like the ‘modern router’

Playstation Network

Dish TV Sling App

and a couple other random web services just won’t pass data through the ‘modern router’

add Zwift to the list…

I switched both the phone and PC over to the ‘antiquated network’ and BAM instant connection…relief and frustration all in the same resolution…

anyone who knows anything about what setting that is in the router I’d love to know…it’s so random and stupid as to which service fail…

so, I’ll ride tomorrow and see how it really works, too much pizza and beer on my off day…i better hydrate…

any suggestions on where to get started on the island ? or just RIDE and see what happens ? 

THANKS ALL !

(Stu Berry) #79

Just ride mate! 2 laps of Watopia! It’s a whole new world. 

(Kevin Young (CNW)) #80

Hey.  Have been using the BLE Beta successfully for some time with a Wahoo Speed and Cadence Sensor.  I was excited to learn that we don’t need to use the BLEBETA promo code anymore.  After a minor setback I was able to get it working.  Below is my sequence - hopefully will help Zwift to troubleshoot and others to connect.

  1. Start Zwift.  Ignore the “No ANT+ dongle message”.
  2. Start the Zwift iOS app (make sure bluetooth sensors are on).
  3. Press esc on the screen that allows you to pair equipment.  For some reason I can’t get it to connect at this stage.
  4. Start the Ride
  5. Press A on the keyboard.  Now the bluetooth sensors will pair.  

Have fun!

Kevin.