Bluetooth dropping during ride, won't reconnect without quitting

Thanks everyone, I too have had many problems the last month.
My rider just slows and stops, sometimes I can hop off the trainer disconnect and reconnect the power and it starts working again without losing too much time but for a race I am toast.
I use a Saris H3, 1 year old IPAD, and new iphone xs on bike for zwift companion.
I thought maybe it was the blue tooth wireless ear phones but everything worked all year until about a month ago. I plan to not use those and try the old plug in to phone style with cable for music next ride to see if it helps the drop outs.
I have the latest trainer firmware upgraded last week and the latest ZWIFT and companion versions.
I will continue to check this thread, Thanks.
This reply is in 2 different threads so I can keep checking for a solution or upgrade by Apple or Zwift or Saris.

Hi guys, thank you for being so active on this topic.

I purchased a Saris H3 in late November, and in no time, I started having BT issues.

My setup is:

  • Saris H3
  • Ipad 14.2 now 14.3 with ZG, and BT connection to Polar H9
  • iPhone with 14.2 now 14.3 with ZC and BT to speakers
  • Garmin 530 connected to Polar H9 via Ant+ and Garmin Vector pedals

As most of you know by now, the above was a recipe for disaster, so after reading all your comments and closely following all of Scott’s recommendations, I have successfully ridden twice with no issues what so ever. What have I done:

  1. Disconnect the location on the Ipad
  2. Disconnect the BT on my phone

As a result, I have to listen to podcast music on my phone, but that can be solved with a Sonos speaker (I have a couple I can use). All in all, I think that pt. 2 is the key here, not so much the location, but I will collect more data in the coming days.

Again, thank you all for your guidance and support. These threads reinforce my view that there is more on the internet than trolls and hate.

Best,
Guillermo

I’m a newbie. I have a Saris M2. I have an iPad and an iPhone using iOS 14.3 and a Polar heart monitor with BT. In the middle of a ride, my avatar stops and pulls over to the side of the road. The time stops and my speed, cadence, watts, and pulse go to zero. I don’t think I died. If I can get there, the app indicates I have connections to the sensors but no signal. Twice, I’ve been able to get them restarted (don’t ask me how) but I usually have to end the ride and start another. I contacted support and was told I had too many devices connected. My latest attempt to ride, I didn’t use the heart rate monitor and left my iPhone in airplane mode with BT turned off and still got dropped. My next attempt will be to try to turn off the keyboard to the iPad with BT connection.

Quick update. Since rolling back the apple TV version (see earlier post), I have now completed 7 activities of between 1 and 2 hours and not a single drop out. This includes group rides without any issues.

I have recently been having the same troubles. My specs:

  • Apple TV
  • Tacx Flux 2 (me)
  • Tacx Flux S (wife)
  • Galaxy S8 for Companion App

My setup has been working great for the past 8 months since I got onto Zwift. Now, all of a sudden, and seemingly too close to be considered coincidence, I have experienced bluetooth connection loss on regular rides, training plans, and TDZ rides ever since TDZ came out.

On my rides and training plans I am usually able to go into the pair menu, remove the trainer, re-add, and in 15 seconds I am pedaling again. However, TDZ Stage 3 today, La Reigne, 1.5 hours - 20km - 900m in, and my trainer drops, as it has been doing at least once every ride for the past week or so. I go into pair and no matter what I do I get No Signal. Absolutely nothing in my setup has changed.

  • I try to hop on my wife’s Tacx Flux S just to pound out the last 300m climb. As soon as I select her trainer, No Signal as well.
  • I unplug both our trainers and plug mine back in. It sees my trainer again. I select it. No Signal. My HRM is fine though.
  • I load up my Tacx Utility App - it immediately sees my trainer is on and active. I connect and give the pedal a small spin and it detects speed and cadence. I close the app and force shut it down as I always do to ensure it is not running in the background creating cross-connectivity issues.
  • I do an internet speed test. 100+Mbps d/l ; 11+Mbps u/l - all good.

So, internet - check, trainers showing up and connecting to other apps (Tacx Utility) - check, both trainers showing as No Signal as I attempt to repair during this ride. I can only determine that the point of fault is the Apple TV as it is highly unlikely both trainers would coincidentally have the same problem.

I reluctantly end my ride, unable to complete La Reigne for the badge and also unable to complete TDZ Stage 3. Needless to say I was fuming. I close out the program, reopen, and all of a sudden my trainer connects just fine and ready to ride.

Afterwards I go to the App store on my Apple TV just to have a look at the Zwift App and I see there is an update available. I found that odd as I find it always updates on its own. I do the update and have not ridden since.

So…

  • Anyone have similar issues as of late (i.e. around when TDZ started)?
  • Anyone know if this random update you have to install yourself fixes the problem?
  • Anyone know where I can go to look at these updates and see the dev logs for what they are actually updating?

Thanks for any help. My last week of riding has been extremely frustrating with at least one drop per ride. All I get from Zwift so far is the generic “maybe you have too many BLE devices in the area” response. I wrote them an email with this same info and am hoping to hear back soon…

Cheers,

Joe

Hi, new here. I have been having these issues also.
Saris H3, iPad Air2 or iPad Mini4 (whichever is free at the time), bluetooth HR strap, iPhone SE for ZC and chatting on Discord to club mates with Bluetooth earphones.
I am the laughing stock of my club for all the times I drop out of rides due to this Bluetooth issue. It’s really not funny anymore.
I bought my Saris H3 just before the iOS update that seemed to be the trigger for this problem. Because I’d only had the trainer a short while I didn’t associate this fact until reading this thread.
First off I thought it could be that my WiFi wasn’t great down in the garage, only getting about 20mbps, so I tried various different ways to improve it. It didn’t help. Even though I knew it was Bluetooth dropping out I persevered with getting a better WiFi connection, until I’m now getting 50mbps, and no Bluetooth dropouts - for a week until last night😡.
So, since November I’ve been using the exact same set up with either iPad, with ZC on, sometimes off, chatting on Discord, sometimes not on Discord, sometimes accidentally leaving my Fitbit on (Bluetooth to phone), sometimes with a fan on, sometimes with it off. I can be riding with just the trainer on, or riding with all of the above on and I can get this issue, or not get it. The dropouts are completely and utterly random and have no pattern whatsoever.
My question is, how do we resolve this? No one has had a decent reply back from Zwift, so how do we move forward?

Utterly frustrated,
Steve

So far, it seems that who solved it, did it by removing one of the variables out of the equation.

People replaced iOS devices with PCs with ANT+ and were successful in getting a more reliable Zwift experience.

Others replaced Zwift, as other apps don’t suffer the same Bluetooth instability with a Saris H3 trainer.

Others are patiently awaiting, crossing fingers at any iOS or Zwift or H3 firmware update (I am among those, while using other apps for races etc).

I’ve just started having these issues today. After nearly a year of flawless connectivity my SARIS H3 and ipad pro + iphone 6 (companion) I got two compete bluetooth disconnects (inc TickR HRM and 4iii crank PM I use for cadence). No Signal message for all of it. Couldn’t reconnect until I force quit zwift and restarted.

I’ve posted in this thread before. I decided to “roll back” the apple TV system to the one mentioned above in the thread. done 4hr riding with no issues now. I have turned off Apple TV auto updates to ensure it stays on this version

In order to get Zwift attention on this issue, how about synchronizing everybody that has been experiencing this issue (I have) and open support tickets with the same title and error report?

One would think that an unusual large number of support tickets linked to the same issue and opened simultaneously or within a short period of time would give a hint to Zwift that there’s a widespread problem.

I’m happy to raise a ticket, it’s getting incredibly frustrating now.

Where do we go to raise support tickets? I have had a quick browse around and there is nothing obvious on the website?

Quick update after a few more days of ditching the iPad for my MacBook Air. I have now ridden for several days in a row now with no dropouts at all. I have my Wahoo HRM connected along with the Saris H3 to Zwift on the laptop, while streaming a podcast through my iPhone to a bluetooth speaker.

It is obvious to me that it is an issue with the Zwift app for the iPad, or something with the iPad itself. I had been exchanging emails with Zwift reps about the issue and after pressing them on the issue I was told that they were going to forward everything to their tech team to see if they could figure something out. That was almost a week ago now and I have not heard back, though the rep did say that it could take a while for them to respond. Finger crossed.

Tyler

1 Like

You’ll find a button to email the support team at https://www.zwift.com/uk/contact-us

1 Like

I have opened a ticket weeks ago.

After about 1 month of wait, the answer was to check and see if the Zwift update that had been delivered meanwhile solved the issue.

Good luck !

This might be of interest to iPad users who also have the use of a separate power meter (crank or pedals).
Today I’ve just completed TDZStage3 ‘A’ up Ventoux with no dropouts on the stage. I’d turned my phone off completely so just had the trainer and HR strap connected to the iPad.
But after the stage I decided to continue on to the top of Ventoux, and yes you guessed it, it disconnected after 10 minutes. I got off the bike to shut down the app and finish my ride, but I thought I would see if I could reconnect the trainer first, but as before, no luck…BUT, I kept my finger on the tap to pair power source button, and it picked up my 4iiii crank power meter, which I’d fitted to compare power figures a few weeks ago.
Fantastic, I could jump back on and continue the ride. This is a game changer for me as I will be able to continue rides without having to restart the app. I couldn’t reconnect the HR strap though.
Obviously no good for races, but this might help some people who can use another power meter as back up.

Steve

Anyone had luck getting this resolved? I’m continuing to have issues. Can’t complete most rides or take part in races.

Hi Valerie, have you had the latest Zwift update for ios?
Says a bug fix for Bluetooth.
Has anyone had problems since this?

Hi all,

i have the same issues agaian and again. Multiple drop-outs.

Saris H3
IPad (6.th Generation) Softwareversion 14.3
Zwift 1.0.60640
Saris Utility 1.1.42

Actually i power off my BT for the Iphone. But that doesn´t help so much. I lost BT connections betweens saris h3 and Zwift on ipad nearly 3 times a hour. It is absolutly frustrating…

Does anyone have an idea?

Thank you!

I literally go hours sometimes days without a dropout of course the past couple of rides yesterday and this morning I had a dropout it’s horrible especially in group rides, I guess this is what happens when you have multiple vendors involved and everyone says it’s not my issue

I’ve reverted to using my daughters iPad 2 with iOS 13.5. Haven’t had a single drop out in the last 2 weeks of riding.

iOS 13.5
Saris h3 sending Bluetooth to the iPad and ant+ to my garmin, Dual band hrm Garmin, 4iii power meter, companion app on my iPhone and Bluetooth headphones.

I’ve got everything but the kitchen sink going without issues, but as soon as I try my iPad with 14.3 dropouts galore.

I’m glad I have a solution, but since once you upgrade the iOS you can only go back via a factory restore it’s not a solution for everyone.