Bluetooth devices connect, but No Signal [January 2022] [Windows11]

Same deal here. Worked fine on Windows 10. Upgraded my machine and system to Win11 and no dice - connects then immediately switches to “No Signal”. Have new Motherboard/CPU/Vid Card, but same BT dongle. Happy to help out with diagnostics or any other debugging you may want!

Same problem for me, have 2 different machines with Windows 11. One with integrated bluetooth (laptop) and desktop PC with bluetooth dongle.
Instantly says “No Signal” just after pairing.
Would be nice if Zwift could support Windows 11 finally. Please respond Zwift-people, whether you are looking into it or not.

I was having same exact issue (Win 11 with a Direto). Now working again this AM, after the following (not sure which corrected).

  • All windows updates applied
  • New Update to BT driver on PC
  • Zwift 1.25 update this morning

Interestingly enough - KICKR Bike works fine on the exact same build of Windows 11 on my Lenovo but not my MSI… until I checked something… Bluetooth drivers? Nope! Up to date.

Except they weren’t.

MSI gives a Windows 10 driver update for what they have “certified”. It was EONs old. Sure enough, it was what was installed.

I went to the Intel site and downloaded the latest Windows 10/Windows 11 driver - the landing page is here (go here if you use a Windows 11 system with Intel - check the chipset list):
Intel® Wireless Bluetooth® for Windows® 10 and Windows 11*

And sure enough? Problem solved. FLAWLESS again!

Don’t trust “drivers up to date” unless they are actually up to date. The problem is that I think several OEMs got “lazy” for Windows 11 compliance and they assumed the safe path “don’t touch the drivers”, which clearly backfired on my system.

3 Likes

I’m running Windows on a Dell XPS, and I have issues connecting after the last updates from Zwift and the 0.38 firmware update on Tacx Neo 2T. My husband has no issues.
My difficulty is that I can connect to Power Source and Cadence albeit with No Signal, and the Controllable will not connect and I can search for it for days and it wont find it.
I have rebooted. I have killed Zwift App and re-installed. I have killed Garmin Tacx App and re-installed.
I have made sure bluetooth on my phone is off. I have started Zwift and checked blue tooth light is off on the Tacx
before-hand and connects when Zwift starts, yet I still have this problem.
Please help. :frowning:

I’m on Windows 10Pro, and so is my husband. but his works.

I haven’t updated my laptop to Windows 11 during the last 2 years to keep Zwift running, was the issue solved?

This feels like an continues issue. I had no issues using ANT+ for years. Recently I bought a new HRM and thought I would switch over to Bluetooth. I cannot get Bluetooth working properly. Same issues described here with Windows 11. Any other Bluetooth devices pairs fine with my PC. Just Zwift pairing acting up.

Jan 2023.
Brand new Zwift Hub works fine with Zwift on android but fails with Win 11 latop due to BT lost signal on start of ride.

Cannot believe this is still ongoing.

Many disconnections from bluetooth here too with my zwift hub, connected to the bluettoth of the computer or to my cell phone… what does Zwift do about that?
If it works fine with ANT+, I will give it a try but bluetooth is so convenient!

I don’t know if it will be better with ANT+ (possibly) however you should be aware that virtual shifting on the Hub trainer requires Bluetooth. If it’s a Hub One you would need to put a normal cassette on it to use ANT+.

Thanks for the info Paul, I was not aware of that.
For the moment I have a normal cassette but I will not forget that if I want to change.
I think I will add another drive to my pc and boot on windows 10 to see if I have less problems :slight_smile:

I would first suggest you get an external bluetooth usb dongle with an extension cable so it can sit right under your trainer. Most likely the bluetooth signal from the computer is too weak. Did you also try updating the driver like Greg did?

1 Like

My computer is up to date with the latest drivers from Lenovo.
Regarding the BT signal, when I pair my Hub with my Phone, distance (from the hub) is not more than 1m, it doesn’t seem that far! And when I use my BT headset, I can go to another room with no disconnection and with my previous computer I had no problem. So either it is related to win11 or to an update from Zwift.
I just installed the Intel BT driver as Greg said. I will test asap and keep you posted.

Well from my experience the onboard bluetooth was just not strong enough, maybe the trainer ftms bluetooth signal is more complicated than headphones? I dont know, but when i switched to an external dongle and extension cable all issues went away.

I tried using my the BT on my motherboard, and it just didn’t work. It would connect sometimes, but then say “No signal” right after. When i tried to connect, i saw that the BT-signal only had 1 bar. Then i disabled the onboard BT in windows (can be done in “Device manager”) and used my BT-doongle instead. That worked. I think its a software mistake, from either Zwift or Windows 11, that’s the reason why it wont work.

1 Like

I had this issue and resolved it.
Open bluetooth & devices in windows
Expand devices
Under device settings → Blue tooth devices discovery → pick advanced in the dropdown
(steps after this are possibly not required)
Click add device and select your fitness device
In my case it never completed but when I went back into zwift it was working properly.

1 Like

I have had this issue today with Samsung A8 tablet and elite tuo trainer via Bluetooth - can anyone recommend anything?

Mike you are the best :grinning:
I updated the intel wireless driver and moved my computer 30cm closer to my Zwift Hub and the magic happened (so far): 6 rides and no more disconnection problems.
Thanks to you and Greg for the driver!

3 Likes

Glad you figured it out! Ride on! :ride_on: