Bluetooth broken since update

I meant to reply to your post with the ANT+ suggestion…

The update from 1/25 seems to have fixed everything up! I rode yesterday without an issue

My wahoo kickr bike doesn’t use ANT +. So I don’t think that is going to help me.

It should. Mine does. In fact I rode it this morning paired in ANT+.

Right! I will give that a go then. :ok_hand:

Here’s the procedure from the Wahoo Bike Buttons thread:

"I just unplugged the ANT+ dongle and plugged in the Bluetooth dongle, then rebooted the computer. It should see the dongle and let you know it does. Then start Zwift, chant the appropriate incantations, spin counterclockwise three times on your left foot and hope it works. Mine worked fine when I did this. :crazy_face:

Let us know how it works out."

Yeah I don’t have an ANT dongle on my computer so I can see there are issues already. :smile:

Until the recent update I never had an outage on Bluetooth. So i’d be hopeful Zwift actually fix the problem? :pray:

Take a look here:


I have the Anself ANT+ unit with a 6 foot extension cable. Both from The Evil Empire, Amazon. My Bluetooth dongle is also from them and when it works, works fine.

So an update on this. I’ve had three rides since my last bluetooth outage and they have all been ok. Except for today, it cut out in the Jungle. Again I had to unplug the wahoo bike and pair it again with Zwift to get it going again. I think it’s the new steering that is causing the issues. I turned this off and the rest of the ride was fine. I’m going to keep on turning off steering for the time being to see if this removes the problem completely. Yes I could get an ANT + dongle but before I go there I will do this final test.

Hi,

Suddenly, I am no longer able to connect my Elite Suito via Bluetooth to the app (Macbook Air). Heart rate monitor and Elite Sterzo connect via Bluetooth no problem. The app searches but can’t find the Suito. If I select the option to pair via the Companion app, that works fine - I’m just not able to connect with the app. Any ideas?

Check that the Suito isn’t already paired to another app, or another device.

Thanks Steve, will check that!

Hi Steve,

I thought I give an update.
I got it paired, but it no longer pairs automatically, like it did flawlessly until now.

Here’s what I did:

  1. Turned off all other devices except laptop (so I knew it was not paired to anything else)- no luck.
  2. Deleted com.apple.bluetooth.plist file - no luck
  3. Deleted all bluetooth devices from Macbook & reset bluetooth module - no luck
  4. In Zwift, tried connecting power meter manually 1st (I had read this somewhere) - it worked, but did not sense controllable, I had to connect that manually as well.

So long story short, it works, but no longer connects automatically.

Strange.

Happy riding!

1 Like

I’ve switched back and forth between the ANT+ and the BLE on my Kickr Bike to enable steering. Every time I pair on Bluetooth I lose HR pairing during whatever ride I’m doing. It doesn’t need to be group ride now, it drops out on freerides. ANT+ is rock solid, just no steering. Currently, that doesn’t matter much since there are only about 47 events available each week with steering enabled and they all start at the wrong time for me…

Is anyone getting this issue since the last update?

I’m on an iPad Pro with the Kickr Bike and I’ve had three rides now where everything Bluetooth has randomly disconnected, the bike, my Tickr and my BT headphones.

Have also noticed that steering hasn’t worked either since the update.

Any ideas would be gratefully received.