Bluetooth audio slowing down on startup

Hello,

I tried searching but couldn’t find another report of this.

If I’m connected to bluetooth audio when starting zwift on my mac (Monterey 12.6) audio is slowed down. Even if I close zwift audio is slowed down system-wide.

Audio example (m4a) of what happens when I start zwift. The forum didn’t like the link so be sure to remove spaces around “com” to listen to the problem.

drive.google. com /file/d/13kjibipRcq6jWmfOuorvJgCAQ3CSbGKo/view

Perhaps an issue with my Bose QC35 but it only happens when I’m starting zwift.

Het, I thought I was the only one!!! I’d been searching for another report of this for months now and here’s what’s happening for me.

I use a Bose SoundLink Color speaker for bluetooth audio. I have a Wahoo Kickr Core trainer (old version) and Zwift connects to it directly with bluetooth. A year or two ago I was on an M1 Mac Mini running macOS 11 Big Sur and there were never any problems. Then I upgraded to macOS 12 Monterey and the fun began. The same exact thing happened to me.

Steps to reproduce:

  1. Connect to bluetooth speaker and switch to it as the audio output
  2. Begin playing audio (apple music, spotify, youtube/soundcloud, doesn’t matter)
  3. Launch Zwift
  4. Part way through the Zwift loading process, before you connect to your trainer, the audio will immediately slow down and lower in pitch. It’s almost cartoonish. The Zwift audio is also affected; it will also be slowed and lowered. After the audio gets ‘behind’ enough, it will kind of garbled-skip ahead to ‘catch up’.

Even after exiting Zwift, the audio remains slowed. I have to turn off+on bluetooth and reconnect to my speaker to resume normal audio.

Things I have tried:
-Using a different Mac (recently got an M2 MacBook Air and the exact same problem occurs)
-Upgrading to macOS 13 Ventura (same problem occurs)
-Connecting to my Kickr via Zwift Companion app (same problem occurs)
-Downgrading to macOS 11 Big Sur (actually DOES work correctly. But I should be able to use the latest OS!)
-Using non-bluetooth wired speakers (works perfectly, of course)
-Running the same bluetooth speaker + Zwift on a Windows machine (works perfectly)

Things I have not tried:
-Using a different bluetooth audio speaker/headphones (I don’t own any others)
-Connecting my kickr core via Ant+ (I don’t own the required ANT+ dongle)

I notice that Het is using Bose headphones and so I wonder if the issue has to do with the way Bose-specific bluetooth hardware interacts with more recent versions of macOS (Monterey and Ventura). I suspect that if this issue were universal to any/all bluetooth audio devices in macOS, we would have heard a lot more reports about this by now.

I consider myself technically fluent (comfortable with the terminal and log files) so I’d be happy to help dig around for some kind of information on this - but I would need someone to tell me where to start!

Hello George! Sorry to hear you have the same problem. But the fact we both have Bose is interesting and hopefully takes us closer to a solution.

I tried starting Zwift while playing music on my Airpods Pro and no problem. Like you say, there would probably be more reports if this was a universal problem. But I feel like Bose are pretty common so I’m still a bit surprised that there aren’t more reports about this.

Any more Bose users out there who want to try starting zwift while listening to music?

I’ve done some more googling and found just a few more examples of similar issues people have had with Bose bluetooth devices on Mac playing slower/lower audio. Unfortunately (or fortunately?) these reports were not for Zwift, but for other applications on Mac.

  1. reddit. com/r/bose/comments/rcndyc/new_bose_qc45_headphone_audio_sounds_like_slow/

  2. reddit. com/r/civ/comments/t4gs6f/audio_is_slowlow_on_macos_monterey/

#2 is interesting because the report is for Civilization VI, a game I also play on my Mac, though I’ve never tried it with my Bose bluetooth speaker. I just tried it today and unfortunately the same slow/low bluetooth audio issue occurs. This means, importantly, that:

This issue is not unique to Zwift. There are several other applications out there that trigger the same issue with Bose bluetooth audio on Mac. I would assume from my past experience troubleshooting that the issue is present in Monterey and Catalina but not earlier versions of macOS (Big Sur).

What I’m not looking forward to is seeking a solution from either Bose or Apple. I’m sure each of them will point a finger at the other, or blame the developers of the software applications… I’m kind of hoping the relatively smaller user base of Zwift might help us find a resolution here.

Hi het and George,
I’ve got same issue but usually with built-in speakers and only sometimes analogue headphones via an audio interface (mainly for music but also got tired reaching behind the iMac to plug in the headphones).
I believe the issue started some time last year.
The easiest fix for me is to open Audio-MIDI-Setup and switch the output format to another sampling rate.
I’ll have to check if Civilization VI also does that. It’s been a while since I last played the game and I believe it was on the Windows side of Bootcamp.

Hey,

Thanks for describing this issue and the tip with the MIDI sampling frequency. I had the audio slowdown on pair of sport headphones (MPOW Flame2), but not on a different set of headphones (WH-1000XM3) on an M1 Pro running Ventura. Starting Zwift while music is playing changes the sampling frequency from 44khz to 48khz on the sport headphones, and I can’t change it in the Audio MIDI menu. The other headphones work fine and stay at 44khz. If I restart the sport headphones after e.g. Spotify and Zwift are already running, the sampling rate remains at 44khz and I don’t seem to have audio issues. It’s still possible that the Zwift audio is sped up, but I didn’t really notice any problems.

I too am running into this issue, started periodicly with Bose Sound Sportfree Wireless after MAC OS upgrades - however my process # 2 would normally… resolve

various tests across 2 different MACs (intel) 12.6.2. and 12.6.3
and across various bluetooth headphones

The below process (#1) has been tested across one of my MACs 12.6.2 (recent rebuilt, approx 4 weeks old)

  1. Connect to bluetooth headphones - auto switches as audio output
  2. Begin playing audio (spotify)
  3. Launch Zwift
  4. Part way through the Zwift loading process, before you connect to your trainer (kickr (BT)), the audio will immediately slow down and lower in pitch, on some head sets the audio gets so slow it stops, then starts in the same slow/low pitch
  • Jabra Elite 7 Active - Audio Issues
  • Sony WH-1000XM3 - Audio Issues
  • Plantronics Focus - Audio Issues
  • Bose Sound Sportfree wireless - Audio Issues
  • Cheap imitation apple air pods - Audio Issues
  • Apple Airpods Gen2 - NO Issues

However if you disconenct/reconnect the bluetooth device or adjust the connection process (#2) like so, you get varied results as noted in 4.

  1. Begin playing audio (spotify)
  2. Launch Zwift, connect kickr
  3. Connect to bluetooth headphones - auto switches as audio output
  4. Some BT headphones are fine, some not. Headphones with issues - after headphones connected the audio will start, then pause mometarialy slow down and lower in pitch.
  • Jabra Elite 7 Active - Audio Issues
    These are my new earbuds for zwift and are only a few months old - started out fine and gradually became worse - and now just wont play ball…
  • Sony WH-1000XM3 - Audio fine after disconnect/reconenct - NO Issues w/ adjusted process
  • Plantronics Focus - Audio fine after disconnect/reconenct - NO Issues w/ adjusted process
  • Bose Sound Sportfree wireless - normally disconnect/reconenct would work, sometimes had reboot my mac
  • Cheap imitation apple air pods - Audio fine after disconnect/reconenct - NO Issues w/ adjusted process
  • Apple Airpods Gen2 - NO Issues

Hi All,

Thanks for your additional feedback, and for proving that “there are dozens of us!”

I just did some testing and can confirm what Felix and Max H observed. Opening up Audio MIDI Setup, I see My Bose BT speaker connects at 44100hz by default. When I open Zwift, it automatically changes to 48000hz, but Audio MIDI Setup doesn’t let me change the sampling rate for that speaker.

Mac internal speakers seem unaffected by changing the sampling rate. It does seem that some (most) BT devices are unable to successfully handle the change in sampling rate, as seen in Mikey’s results. I was unable to get my Bose speaker to sound correct no matter when I tried reconnecting it.

As a hack/experiment, I wonder if we can somehow force Zwift to stay at 44.1khz?

Found yesterday and today (Jabra Elite 7 Active), if I only connect a single earbud (right) the audio is fine, I give it a few seconds, maybe ten, then remove the left earbud from the case and let it join in… so far this has worked.

For me, - I’ve always had to follow a strict process when using wireless earbuds

  1. Launch zwift
  2. Let kickr and BT HRM connect
  3. start riding
  4. connect earbuds… and now it seems, one earbud at a time

Mikey, great! This workaround did work for me. I feel a little dumb for not trying this long ago. If I just power on my Bose speaker after Zwift starts, there are no sampling rate issues and audio is normal.

But if you have it on before Zwift starts, Zwift will try to force the speaker to run at 48khz (even appearing to successfully change it in Audio MIDI Setup) though the speaker won’t be able to handle it and has the slowdown/catchup behavior we all encounter.

So I suppose the core issue is that when Zwift starts up, it forces the active audio device to 48khz. I wonder if the Zwift devs could simply leave the audio sampling rate alone and just play at whatever the currently connected device uses?

It’s still a mystery to me why this changed in between Big Sur and Monterey, and why it happens with some other applications and games too. I’ll keep digging for answers.

But for now, I’ll just change up my pre-ride checklist a little, powering on the speaker and starting music as the very last step. That said, I’m still interested to hear others’ experiences and ideally get this fixed.

Connecting one at a time is no longer working - I’ve logged a support ticket asking why zwift is changing the audio from 44khz to 48khz - referring support to this thread. If anyone is experience similar please do the same