Blank / black photos from Zwift companion app

Hmmm… unless I am missing something, “pressing F10 on keyboard […] no photo taking” and “when I use laptop for Zwift, everything worked fine” are mutually contradicting.

Or am I missing something here?

(Zwift, the sound of silence…)

Two different devices, PC and laptop?

Anyway this was resolved by someone I know by reinstalling Windows. Guessing something is blocking Zwift from creating files in the Documents folder.

Traditionally, this was attributed to OneDrive. I wonder…

1 Like

Yeah I checked that with the chap in question (and any other cloud backup service) but he said had none installed. Wondering if at some point, AV software asked if Zwift was allowed certain permissions and he said no by mistake.

Yes, I also have this where the *_clean.jpg files are fine, but the ones with overlays are black.

If I Alt-Tab to the Windows Desktop, and back to Zwift, it starts working again.

It’s not the companion app that’s at fault. It’s Windows. And it’s not a space issue either.

I have the same issue, running Zwift on my Galaxy S9 and all I get is black screenshots, I tried un-installing ZC (also installed for when at home on PC) to see if that made a difference but no. There is plenty of space and both have all the required permissions. Any ideas?

1 Like

Samsung galaxy s9 plus. During the new user trial, twice there were non-blank screen during photo upload, then it is blank/black.
Somehow I expected that they are unable to manage it. However 4 years for this bug… Well. What can I say.

Maybe they will need some time (10-15 years) to fix the black screenshot issue.
Why?
20 (twenty) days ago I requested an exceptional, very challenging and difficult change where excellent teamwork and perfect scheduling would be required.
I requested to fix a typo in my day of my birth as accidentally the 01 was setup instead of 31. So technically a 0 should be changed to 3. They requested a couple of days the weeks.

They have been trying to solve this extremely difficult problem for 20 (twenty) days now.

Well.
Good luck for the solution.

By the way. Why the android application would need access to camera?

I’ve just switched to Windows and have started getting this problem. Black images uploaded as screenshots and often I get images of the pairing screen uploaded too.

I was previously using an ipad, with an android (Samsung s10+) companion app and screenshots would load normally - either automatic or snapshots I took myself.

The current set up is a Windows 10 business level laptop connected to a TV via HDMI and runs full screen on both laptop and TV. Works beautifully, except for this issue.

I have the same issue. I am running
Zwift on Samsung Galaxy S10e using DeX on HDMI connected monitor in full screen mode with Companion app running on the phone. Every photo I take is pirch black. There’s plenty of room on the storage an all permissions are granted.

@Tomasz_Piasecki Try running Zwift in windowed mode instead of full screen. Mine works fine when I switched over to windowed.

If I grab photos using the ZCA, they always show up black in the Save screen on the Anroid tablet. There is an icon of some kind in the top right corner of each photo, and tapping on that causes the photo to appear. Then when you save the ride, the photos are saved.

The other thing I’ve noticed is that taking photos on the tablet running the Zwift game uses the built in screenshot function, so you can get various kinds of clutter. Using ZCA just captures the picture – no dashboard, no leader boards, no list of nearby Zwifters, etc.

Screen capture/upload has been broken in multiple ways for over two years now with no solution in sight.

Each to his/her own solution :frowning:

Hi, another newbie here. While there is a temporary solution with Zwift on Windows (windowed mode), how about the solution for Zwift on phone app?

I am using Honor 8X as my Zwift and Oppo F1S as my Zwift Companion.

Thanks.

Eko

Hi,

I’ve seen a lot complaints regarding this. Do note, however, this issue is not universal. Screen image capture being broken as it is (and it is - still!) does not include - for me - any “blank” photos item.

I am at a loss as to what is the logic to this behavior.

Seems to have been fixed in one of the recent updates? Working OK for me now.

No so fast. The problem persists, at least for me. Yesterday, on a Zwift ride, my Zwift was running full screen, All of my screen shots were black blanks. Today, under identical circumstance with Zwift again running full screen, all of my screen shots were good. I have noticed this problem come and go rather randomly over the last six months. I works more often than not, by the way. I ride everyday and I note each time it screen shots don’t work. The occurrence of the problem seems unpredictable. I am using Zwift Companion with Zwift on the laptop.

Same for me with HP Elite 850 notebook on Windows 10 Enterprise since begin of Mai. With desktop PC, on windowed mode and photos without HUD overlay is working only.

Im having the same problem since last update. I checked memory space on my iPhone (where I use companion) and have a couple of gigs free. What do I do?

I started back into Zwift on September 1 (off for the summer season!). I take screenshot pictures with the Companion app and then before uploading from my Apple TV turn the data off so I got a clean screen shot. Worked fine for years. Now, when I turn off the data I get a blank/black image.

If I leave the data it uploads the screenshot with the data. If I remove the data it uploads the screenshot black.

I use an Apple TV - non-4K with IOS based companion. Latest software on both units. Latest operating system from Apple. Lots of available memory. Deleted Zwift and Zwift Companion and reloaded – same problem.

Issue also occurs when I use my iPad instead of ATV.