BKool power calibration in workout mode


(Scott Burrill(BIKEMAN.COM)) #1

While in workout mode during warmup phases or any ERG section the power calibration seem way off.  To maintain a 120w level I have to spin in lowest gear at  a 25-30 rpm to even match and even then it seems to jump all over the place. Am I doing something wrong?


(Simon Whittaker) #2

This is happening to me as well. It has happened since the last update for both Zwift and Bkool. During warm up, first gear and 50 cadence is 120 + watts. during the first section of the work out same gear and 80 cadence is giving me 300 watts. very uncontrollable.  

Any ideas?

Thanks

Simon 


(Scott Burrill(BIKEMAN.COM)) #3

Simon I have noticed that if I stop pedaling and allow the pause screen to come up, you’ll notice it says “ERG mode temporarily disabled”.  Then when I start riding again it feels alot more natural.  Eventually ERG catches back up.

Next ride I am going to try disabling ERG on a workout and see what happens.  


(Gareth Devey #FVC) #4

Did you try that Scott, i had this issue today and makes no sence

 


(Scott Burrill(BIKEMAN.COM)) #5

I have not yet.  Been away from the trainer for a while.


(Martin Burns) #6

I have the same problem, with both the the original Bkool (white) and the newer Bkool Pro (black) in ERG mode when riding Workouts. This only started happening about a week ago. I noticed if you pedal backwards for a couple of seconds this ‘resets’ the ERG mode and you can continue, though not a workable solution if you doing short high power 30sec intervals!!

Any help help from the community or Zwift to resolve this issue would be great.

Cheers, Martin


(Gareth Devey #FVC) #7

Hi, I ran a workout with ERG mode deactivated and I could get better results, however according to the trainer road site Bkool are close to releasing a new firmware version possibly in April that will cure the ERG mode issues experienced.  Until then I would suggest just deactivate it and run in normal mode. 


(Martin Burns) #8

Thanks Gareth, I will try this and report back.


(Steve C) #9

Hi - there are quite a few threads on this, here, on trainerroad and cyclechat. ERG mode on the Bkool units doesn’t work properly - it sets the resistance too high so you end up exceeding the workout power demands.

Bkool had a firmware fix tested and confirmed to work at the end of December but it’s not planned for release until April - as Gareth said. I guess that’s because they’re rolling other firmware update out at the same time.

 

So for now, you have to turn ERG off on the workouts settings page and just use your gears to get to the power required. Hills are ‘flattened’ in non-ERG workout mode so it’s not that difficult and probably preferable if the workout includes full-gas sprints.


(Julien G) #10

Does anyone have an updated on this issue ? For most workouts doing it without ERG is fine, but some of the shorter intervals it is hard to catch up to the required watt levels…


(Steve C) #11

From the trainerroad thread:

"I received an update from Bkool this morning regarding the release of their firmware update!

I know Bkool hoped to have the new firmware out in mid April, but they indicated that it is now slated to be released sometime around mid June.

It’s always good to keep in mind that ETAs (estimated time of arrivals) surrounding software, firmware, or hardware-related releases are just that - estimated. There can be a lot of unforeseen complications that arise when building software, and this can push originally estimated release dates further into the future. Of course, companies would love to be able to roll out updates and new stuff like clockwork, but that’s generally not possible if the quality of the product is a priority.

As always, thanks for everyone’s patience! We’ll certainly continue relaying updates to you as we receive them!"

 

http://support.trainerroad.com/hc/en-us/articles/201697324?page=4#comments