Basic Cybersecurity Best Practices - TLS

Please update your software to support TLS 1.2. Your current client software on Windows only supports TLS 1.0. That version was defined in January of 1999. That protocol is likely older than some of your development staff. TLS 1.0 is not only out of date, it is riddled with vulnerabilities. Please consider enabling support for a modern TLS version, e.g. 1.2.

Hi @Jason_Maddox7824 welcome to the Zwift community.

I’ve flagged this up to our gameops team. Thank you for the suggestion.

2 Likes

So glad your team is considering modern basic security! I love Zwift and hope all can enjoy it too in a secure way.

Best regards,

Jason

1 Like

A mandatory update on my computer seems to have broken my ability to access Zwift because of this issue. I’m not sure if I can Zwift until this is addressed, as only my work computer is mobile enough to be used with my trainer. :frowning: Please allow TLS 1.2 if possible!