Basic Cybersecurity Best Practices - TLS [SOLVED]

Please update your software to support TLS 1.2. Your current client software on Windows only supports TLS 1.0. That version was defined in January of 1999. That protocol is likely older than some of your development staff. TLS 1.0 is not only out of date, it is riddled with vulnerabilities. Please consider enabling support for a modern TLS version, e.g. 1.2.

Hi @Jason_Maddox7824 welcome to the Zwift community.

I’ve flagged this up to our gameops team. Thank you for the suggestion.

3 Likes

So glad your team is considering modern basic security! I love Zwift and hope all can enjoy it too in a secure way.

Best regards,

Jason

2 Likes

A mandatory update on my computer seems to have broken my ability to access Zwift because of this issue. I’m not sure if I can Zwift until this is addressed, as only my work computer is mobile enough to be used with my trainer. :frowning: Please allow TLS 1.2 if possible!

Shuji, can you provide the thread with any updates? As we get closer to the end of 2020 Microsoft TLS 1.0 and 1.1 will loose support.

Has the Zwift dev team announced when they plan to get current on TLS 1.2?

2 Likes

My work recently disabled TLS 1.0 and 1.1 on all our laptops. I was able to use the free Nartac iis crypto application to temporarily re-enable the TLS level Zwift needs to launch. Im good until the next reboot when my company’s GPO pushes out the TLS enforcement policy again.

Hope this helps everyone to keep zwifting!

@D_H

Thank you for the nudge. I reminded the right team that there’s a clock ticking on this.

1 Like

Any update on this?

@Giorgos_Gavriil
It’s actively being resolved. Should be done soon.

The latest game launcher v 1.0.52 has dropped yesterday and should have propagated to severs globally at this point. This version supports TLS 1.2, so I will mark this thread solved.

You can install launcher v1.0.52 by manually downloading from zwift.com/downloads and installing that over your current build.

Does it address any of the stability and performance concerns I raised elsewhere?

Answer is no, anyway. Still not as smooth. Same as before, alternate overwriting the launcher from 1.0.50 to 1.0.52 back to back and it goes from smooth to poor and back again. Really easy to spot on camera 9.

PS: this is yet another different build, GT 1030 this time.

O no, I was hoping this was fixed, I installed the new one with the hope that it is good. :frowning:

The concerning thing is that at some point (due to this TLS update) all older launchers will probably be deprecated. I can’t understand how the devs don’t see it tbh, it’s not even hard to spot. I can notice it immediately.

But can you on a ATV in 4K…LOL :rofl: :rofl:

1 Like

Well exactly. :unamused: