Arrow keys do not work as expected (custom workout editor, end ride screen, drone camera, U-turn, intersections) [1.39.0][May 2023]

After this most recent update, pressing the arrow keys on my Macbook when in a time or watts field in custom workout creation takes me to a different field rather than moving the cursor down the text within that field.

This makes it functionally impossible to type in the durations of an interval. I can still use the sliders, but that is significantly worse UX than it used to be.

Is anyone else experiencing this?


@shooj @James_Zwift @DavidP

The exact same issue happens when you end a ride and try change the “ACTIVITY TITLE”

In the case of the screenshot below, if I use the arrow keys to move the cursor around, it simply moves to the “FOLLOWERS” box on the right.

Mac mini M1
macOS Ventura 13.3.1

Zwift 1.39 (this issue did not exist on 1.34)



1 Like

Hi folks,

Thank you for raising this issue up. We’re investigating this now.

1 Like

Windows 11, fully patched, latest Zwift update.

Cursor “up” arrow used to bring up context bar/action bar. As of the latest update, it now sometimes takes 3-10 presses before it appears.

1 Like

I have seen this mentioned in a few places - might be related to the menu button not appearing too?

I am on windows and it seemed to work okay for me so might be something else at play or an intermittent bug?

The arrow keys are also now swallowed by the ui and can no longer pan the drone camera.

1 Like

Can’t u-turn with arrow down on the keyboard in Win10 after this update….



Same issue for me. Now you have to grab the edge of the block and drag right or left to adjust the time and the top edge to adjust the power. Very finicky. Not ideal

@Gareth_Hay_TT1 , @BooX , if you are still experiencing these issues, can I ask you to open a Support ticket?

I’ve tried to test out these problems on both mac and PC, but I can control the drone camera and do a U-turn from every perspective.

Since the new update you can no longer use arrow keys in the custom workouts to change the time or watts. And there is no right delete button on macs so there is now no way to edit the workouts anymore.

1 Like

I often (read always) create my custom workouts in Zwift- but since the update I cannot move the cursor to edit the set wattage or time display for that zone. The delete button acts as a ‘tab’ as does the up/down/side arrows.
I use 2 year-old Macbook. HELP


Will raise a ticket, but hitting 0 for drone mode and the hitting left arrow just highlights “menu” orange button (pc)

If i keep smashing the arrow key the camera sometimes moves very very slightly but the ui is grabbing it the keypress.

Same in “save” dialog.
Trying to edit the name is all but impossible as arrow keys remove focus from the text field.

Multiple ride sessions, different worlds/events.


Yes I had the issue Monday, didn’t test Tuesday since I was on the Wahoo Bike and used the dedicated u-turn button.
It seems to me that the u-turn with keyboard arrow down works in the beginning of a ride, but then stops working later into the ride… I’ll be riding the Neobike today and will try to see if I can figure when/if it stops working during the ride.


Weird that Drone mode ( 0 ) and arrow keys works perfectly on Win10 here…
I use it for my “photos” :slight_smile:


I got it on camera, you can ignore all the extra overlays, thats just in OBS.
3.19 into Club Ladder // SZ Mumin vs GlucoseGolds // Greatest London Loop - YouTube

You can see I try to switch to drone mode as the camera “wobbles” a bit, but the UI is responding to the left & right arrow keys jumping between menu button and message text entry.

I did also get notification from Zwift

I’m sorry to hear that you’re having this issue. This is a known issue and the Zwift team are working on a fix for release in an update very soon.

@Gareth_Hay_TT1 Thank you for that video. I had not checked the drone camera while in a paddock. Do you also have the issue while in free ride?

It seems to fail at the start of a ride/activity, but I have now been able to get it to work later.
Maybe the functionality is different if the avatar is stationary?

Arrow keys have stopped working for navigation as well. Not just U turns. Whichever arrow key I hit, it’s just focusing on the Meny/Join Race buttons instead of turning.

1 Like

I logged in on my Mac today to change the values in one of my custom workouts. I could not change any of the values or targets for the workout. Arrow keys just skip to the next value, no editing seems possible. I tried on my PC as well, and same thing, except on the PC, I can hit the “end of line” key and delete the value and enter my own.

Trying the CTRL-E (end of line) keyboard shortcut on the Mac broke Zwift, and I had to quit and restart.


I have the EXACT same issue… Any help on this?