AppleTV problems with new update [1.13.0] [May 21 2021] [SOLVED]

IT WORKED!! using 4K resolution, 1st gen ATV, and kickr bike. Now I need to confirm that the new world loaded.

Thank you to all the people on this forum putting their energy into solving this issue!

Now we wait for the next update and I’ll wait a few weeks before installing it.

3 Likes

Wow great catch everyone! Will try this when I get home after work. Getting excited just to hit the trainer for this!

Great job organizing this forum. It’s amazing what some highly motivated people can do when we put our heads together! Now Zwift need to figure out the why!

Thanks :blush:

1 Like

Just curious. I use the AppleTv 4K just for Zwift and the tv I use is not hooked up to any audio. I saw your post and checked my Settings and there isnt an option listed for stereo. Only Auto. I’m hoping I’m good to go, but still not going to update until a fix is actually pushed out. Nice Job!

TV brand is Panasonic TX-40GXW804 with latest software version, video 4K Dolby Vision at 50Hz operations mode.
Connected to Apple TV via 4K HDMI cable at TV HDMI Port 2 with ARC connection.
Apple TV is A1842(64GB) with iOS 14.5(18L204).
Acc. to Apple TV Info the Video resolution of 2160p UHD - 60 Hz Dolby Vision is used.
Audio is settled to Dolby Atmos.
This configuration was working glorious since … last Wednesday. ;0)

It sounds like turning off Dolby Atmos on the Apple TV and going into stereo mode is the workaround for you folks who have fancy TV’s. :wink:

There’s enough of you who’ve reported that lowering screen resolution to 480p is another succesful workaround.

Thanks all for working with HQ today to chase down clues . Rest assured that we will continue to work on a true fix targeted for release in v 1.13.2

FYI - we have also been working on a fix for a similar-seeming macOS crash and the patch for that is v 1.13.1 that’s releasing tonight on macOS only. Just want to be clear that 1.13.1 will not fix the AppleTV issues. We appreciate your patience!

3 Likes

None external audio hardware used , only the amazing sound of the Panasonic TV.
Between you and me, the audio sound of the TV is more playing my Apple audio playlist as the gaming sound. That’s why I prefer the Apple TV and the smooth connection things between other Apple products. The lousy video details of the Apple TV, who cares. Caught well, Nvidia is better.

Confirm your solution, TV is running under highest resolution mode as ever. 3840x2160/60Hz with Dolby vision.
Selected audio Atmos „Off“ at the Apple TV……and…

Yes! It works. Thx.

But hey wait it‘s two o’clock in the morning. Damn, see you tomorrow

2 Likes

@SQR
Enjoy Makuri Islands tomorrow, friend!

Ride on!

1 Like

Ok did a quick check and test…First check res is at 4K, Dolby Atmos is On. Tried to start Zwift, kaput. Go back and change Dolby Atmos to Off. Touchdown - YES! All good for now. But i noticed no in-game sounds. But if I exit Zwift and come back and start a new ride, I get in-game sounds!

PS. DC Rainmaker, big YT athlete did an Apple TV 4K review of new model and old with Zwift. Please check his latest video on that.

Just some hints from his video and hope to see these in the future releases: 1. New remote button functionality working in Zwift. 2. Shadows on objects other than the bike itself. 3. Better, improved graphics. 4. Not sure if this is Apple limitation but more BT device connectivity other than using the Companion app. Bottom line summary as of now, do NOT upgrade to the new Apple TV 2021 yet till Zwift makes some improvements!

No I don’t, just a couple of other apps installed. Though it looks like this is redundant information now and you’ve moved way beyond this. But I thought I’d reply since you asked me.

1 Like

@shooj - yes, worked for me too.
My TV = Panasonic TX40GX800B 40" 4K Ultra HD Smart LED TV (latest firmware), connected to ATV via HDMI.
I set ATV audio to Auto (i.e. switched Dolby Atmos off).
Works absolutely fine now (ATV res is 4K Dolby Vision at 60Hz).
@David_Kalinka - fantastic catch - awesome lateral thinking and troubleshooting!
Nice one everyone - good to see everyone working together to get stuff solved!
Have a great weekend!!

UPDATE:
Just for completeness - I checked my TV with the working version of ATV/Zwift:

  • LG - OLED55C7V 55" Smart 4K Ultra HD HDR OLED TV
  • ATV 4K 1st Gen 64GB (Model: A1842), running version tvOS 14.4 (18K802)
  • 4K Dolby Vision with Dolby Atmos enabled
  • Zwift (latest version) works fine

Interestingly, I have now updated tvOS to v14.5 on the above setup and Zwift still works fine.
So, different TV, 4K Dolby Vision and Dolby Atmos both enabled and Zwift works fine…

The new Zwift update is (once again) full of obvious bugs. Meanwhile I think the software developer team consists of underpaid hobby programmers. I have no understanding whatsoever for such serious errors, that is simply sloppiness.

  • My wahoo bluetooth heart rate strap is no longer reliably detected. The displayed heart rate values have nothing to do with reality and remain constant despite high wattage load.

  • The length of routes and sprint distances is displayed as 0 km/mi.

  • After completing a route (Flatland Loop) my values do not appear in the results list.

And these are just a few examples - no, i don’t bother to post screenshots again and then wait a year until these bugs are fixed.

You obviously don’t learn from your mistakes and enjoy trying the patience of your paying customers.

Finally, pay more attention to software development and less to marketing. After watching this for years, there is no reason for me to wrap my criticism in nice words anymore.

4 Likes

Nail. Hammer. Head.

It is always an interesting study about what is going to be introduced with the monthly Bugdate. There’s usually something we want and look forward to, in this case the new world, which for those of us on PC’s is pretty f*ckin’ cool.

Then we have the new Bugs: Hey! It absolutely does not work with any Apple products! How in the world did that get past QC? Wait? What’s QC? Exactly so. :roll_eyes: :grimacing:

1 Like

I am not getting a crash. using ZCA (updated with Apple TV 4K) to feed Kurt Kinetic control, Polar HRM and Garmin V3 pedals for power, bluetooths (blueteeth ?)

but where as pre update, all of the BT (via ZCA) were recognised every time, now I do not get the trainer control BT registering and non is available when I search
However if I go to the power selection it IS available on a search, (together with the V3 pedal)
Selecting the trainer control in power, then changing the power source back to my V3 pedal, the controlled trainer appears in control and I can continue…

I have a different trainer, but experiencing the same BT issues. Trainer control cannot be found, and when I do reboot the bike, I find it, but lose BT a few minutes into riding and the bike just stops for 10 seconds then BT comes alive and I thought it just my connection…I am also losing the BT connection to the bike. I have a Stages bike and while pedaling can see the power output from the bike on the Stages app. Constant output, but the power display, cadence on Zwift goes blank and 10 seconds later comes back on. Today I purchased another ATV 4K and it does the same thing, so it is not the ATV box. I have been using Zwift on my iPad and screen mirroring to the TV which does allow me to ride, but at a very slow frame rate. This also tells me that it is not the bike.

I am also losing the BT connection to the bike. I have a Stages bike and while pedaling can see the power output from the bike on the Stages app. Constant output, but the power display, cadence on Zwift goes blank and 10 seconds later comes back on. Today I purchased another ATV 4K and it does the same thing, so it is not the ATV box. I have been using Zwift on my iPad and screen mirroring to the TV which does allow me to ride, but at a very slow frame rate. This also tells me that it is not the bike. Please Zwift fix this along with the current audio issue that causes the app to crash opening.

This issue is annoying huh! I’m on Apple TV - if you go back to main Apple TV menu, go to settings, system and restart your Apple TV that should work. Just has for me! :+1: