AppleTV ERG bug in update? [1.17.0]

There appears to still be an issue…

Wattbike atom, Apple TV.

Previously you could toggle erg on/off now you can’t and are stuck in erg…
if you are failing an interval and you end up in the spiral of death you now can’t get out of it… previously you could switch erg off, move to gears and complete the interval…

Now, your knees just have to suffer…

Hi, I am using Wahoo Kickr 2018 and having issues that just make riding on Zwift impossible since the latest version of the application Apple TV 1.17.0

Basically when I allow Zwift to control the trainer resistance is way too high. For example, 200 watts feels like 400. This is on both ERG and SIM or freeride where I use my bikes gears.

When I disable my trainer as controllable from Zwift then I don’t have the issue. I use another application called Fulgaz and don’t have any issue. Kickr and Apple TV firmware both up to date.

I have already raised a ticket with Wahoo and supplied them with a FIT file to help them diagnose the issue. Their response was that the trainer is working as expected.

This issue only manifested itself after the latest Zwift update.

Now I am not getting value for money per my Zwift subscription as are many others. Can this please be resolved asap

I completed a 90 minute workout today via the companion app and all seemed to be working correctly including erg. ATV 4k and Kikr v5.

Not working. I’ve read this whole thread, and everything described is what I experienced the second time this week.

In essence I’m on ATV 1.17.0, and ZC 3.28.1. ERG is erratic, and when you lose the Bluetooth, i.e. no sensor data, re-power on Kikr Snap 2, restores connection, but ERG is basically useless in Pebble Pounder. This morning’s exercise was horrible, due to this issue. When will a new fix be made available?

ERG mode not working yesterday when devices connected to companion app. Connected direct to ATV and worked. Not ideal as I end up losing either cadence or HR

Thanks for posting. This didn’t work for me.

If I avoid the companion app i can get ERG to work - direct to apple tv (or zwift on iphone or iPad). Spent a lot of time troubleshooting though and not cycling.

my set up:
kickr snap 2017
apple tv OS 14.7
Companion 3.28.1
zwift 1.17

Hello,

I was hoping you could help me. I recently bought a Kickr Core and have been using it on Zwift.

I seem to be having some resistance issues. Today when doing a workout, the resistance was all over the place. At one point it was requesting me to keep a power output of 195W and then 225W. No matter how fast I pedeled (between a cadence of 100-140), i could not reach this maxium output (Maxing out around 170W and it felt like I was just spinning). Then when I came to cool down periods where it was expecting me to output 145W, the resistance suddenly went right up, and a cadence of 70 was outputting over 250W (I had to slow the cadence as I just couldn’t spin any faster due to the resistance).

This is obviously no use, and I have tried the following to rectify the issue:

  1. I tried unpairing the Kickr from the Wahoo app when I was on Zwift.

  2. I have done multiple spin tests

  3. The connection seems to be fine, as it is very responsive to the power, so I’m convinced it’s not the connection issue.

I am running Zwift on my desktop PC with Windows 10 via Bluetooth connection. I have the latest firmware installed (1.1.1). I know going back to a previous Firmware can help issues like this. Can anyone advise what to put it back to if this is the case?

If anyone can give me some advice on how to sort this, or if there is something I can do to remedy the issue, that would be great. This is my first smart trainer, so I maybe just need to get used to it, but this was particularly bad on my workout today (I’ve done about 6 sessions now, and the resistance has been very twitchy since I got it. Hopefully the item isn’t faulty).

I look forward to hearing from you

Regards,

Chris