Apple Watch Unpaired Bug

Yes, I understand what Jimmy said and I understand what you say. Use everything you want and what you are comfy with, but the fact is the Apple watch is the most selling HRM in the Apple world, not in the world.

Milan, I have my doubts that HRM straps are more prevalent among Zwift users than watches, which I think is your point. Especially with the pandemic surge of new and presumably more casual Zwift riders. But even if true I think those straps are distributed across a number of brands. I was talking about the sheer number of units from one manufacturer. Apple has sold 100 million watches (per gsmarena dot com) and dominates that market. I don’t think Garmin or Scoshe is selling 30 million chest straps a year…

I used chest straps for 20 years, and have a Scoshe arm band now, but I’d rather just use what is already on my wrist.

1 Like

My point is not only Zwift - you wrote “biggest selling HRM in the world” and that is what I mean. Well, might be it is the best selling at the moment.

i’ve only just subscribed to try it out, but with exactly the same situation as the OP, am also considering cancelling over this. it’s like a 1990s problem!

2 Likes

This worked for me today, thank you!

Omg, the voodoo works! It’s been frustrating to say the least, but now I’m happy.

Thank you!

I think I figured it out. Was able to replicate and fix twice. I have an Apple Watch series 6.

  • When theater mode is off, I’m able to pair it normally, but whenever the light changes or the watch face catches my face the screen fuzzes/obscures and it unpairs

  • With theater mode on, I pair the watch and then wait for it to turn the face off. No issues with unpairing entire ride.

4 Likes

Thank you your tips and sharing the frustration of pairing Apple Watch with Zwift, to my disappointment, Zwift has not bothered to acknowledge your concerns, business must be really good for Zwift

I’m having this issue too. It now completely doesn’t work after an update.

this is an issue for me as well. i find that i have to close the companion app and down and then turn my watch off. restart both and that works 80% of the time

I have a new pattern which works most of the time with my AW6. On the Zwift screen it reliably says it is already paired (with Companion open) at startup. But I need to raise up the watch to view the screen for it to actually make an active link. If it doesn’t start reading my pulse, I force close it (i.e. press the power button and left swipe to close the app). I then restart the watch app. If this doesn’t connect, I just proceed until I enter my route for the day. Before pedaling, I go to the pairing page. It will say connected even if it isn’t really–and then I once again do the raise to view routine again it will often connect. If still no, I try the force close routine again but at this stage it usually doesn’t work- and I just switch to my HR strap at that point. Ridiculous, but I am able to connect the majority of the time overall.

2 Likes

I tested it and. First try shows, you are right.
Theatre mode is a work around!!

I was disappointed Both zwift and apple not to solve or provide clear answer for this matter.
In my assumption,
Apple’s workout app conflicted with zwift companion app., so I’m trying to go to apple watch setup - workout app- deactivate “detect gym equipment”.

I saw sometimes workout app automatically running during my riding with zwift and HR data unpaired. This could be one of the reason.

1 Like

Been poking at these same issues since I got my AW Series 6 this July. What a frustrating month and a half… I was previously running a Scosche armband for HR without any trouble, though I do like the extra Health App and Workout data that using the AW for heart-rate provides so have been motivated to make it work. Easily 10 minutes of each ‘ride’ is spent dorking around with restarting apps and re-setting data connections. Even when it works, there’s so many small blips and twitches that it’s clearly always on the verge of total collapse.

I’ve been struggling to find a successful sequence of steps to ‘fix’ a dropped AW connection while during a ride (because going to the Zwift pairing screen stops your ride, instantly dropping you from whatever group you’d been hammering along with). Only thing that seems to consistently work is killing Companion on both my phone and the watch, turning off the phone’s data connections (wifi, bluetooth) to sever it from the desktop app, then switching those back on, re-launching the phone Companion app, and praying that the watch will wake up with successful HR pairing.

Probably the most useful thing I can add to of any of this is that on some of the dropouts, I’ve noticed a white (not the usual green) Apple Workout ‘running guy’ remaining on the watch face even if I’ve quit the Zwift Companion app, suggesting there’s an still active open data connection… Only thing that kills that open but not-actually-connected connection is starting an Apple Workout then quitting it. (Junhee above might be onto something with the Apple Watch Workout app conflict; apparently I have had that setting switched ON, will turn it off and see what happens.)

Will also try the Theater mode trick mentioned above. I’ve recently noticed a correlation between the watch screen going “blurry” and some of the HR data connection drops where - sometimes - if I look at the watch, it’ll reconnect (if only temporarily).

My setup chain is Zwift desktop app running on a Mac, my Tacx trainer connected to Zwift on the Mac via bluetooth, Companion on my phone acting as a remote-control near me on the bike, and of course the Apple Watch which connects through the phone… all the connections.

I collected some more experience and two hints are missing, I think:

  • you need to do the pairing for each session
  • in the pairing dialog, tap on the watch face to wake up the device

Then you will see ‘selected’ on the watch and after committing the pairing, it changes to ‘in game’.

Wanted to follow up with my experience trying some of the tips shared here so far:

  • Turned Apple Watch’s “recognize gym equipment” setting off
  • Tried running the watch in Theater mode.

This worked for 5 minutes before it all collapsed again.

One aspect of Zwift’s launching that seems to consistently trip up the Watch pairing are all the waypoints and steps particularly when starting a workout or joining an event, particularly those which incur a map change:

  • Initial pairing screen at startup “selected” “in game” = connection is all good
  • Selecting a workout occasionally triggers an AW pairing failure (we’re not even in the map yet)
  • Enter a map = might still be good, might not. In my experience the AW usually drops out after a little while.
  • If you have a pending event, choosing Join Event then triggers a map change, and almost always the Watch connection fails here.
  • If you’ve joined an event, you have to be sure to leave time to be able to re-set the phone and watch connections.
  • If you’ve started an event, and AW pairing fails while riding you are SOL. Going to the pairing screen stops your rider (dropping you from the group) but worse, re-pairing (to AW or a new device) then puts you in a failed dialog loop that you have to quit the app to get out of. Kiss that event group ride goodbye.

So far the only consistent way I’ve been able to re-pair after the failed connection (which can fail either immediately, at a map change, or after a period of time in a ride) is to kill the phone’s data connections to sever the Companion App from the desktop app, kill any lingering workout data activity running on the Watch (if there’s a little running guy on your watch face, start and then stop a watch Workout) and then re-enable the phone connections. This works as often as not…

1 Like

Zwift Dev, is there any news to this being resolved?

This AW pairing issue seems to have gotten worse with the last couple dot releases (circa the new Scott RC and Cervelo S5 additions)

IF (big if) AW pairing survives entering a map, it seems to only last anywhere from a couple seconds to 3~4 minutes. My previous escalations of tricks (severing phone connections, starting watch workouts then re-starting Companion, etc) all seem to no longer work.

Just wanted to chime in and say I see this all the time with the Apple Watch 5 and my iPhone 12 Pro Max in companion mode paired to an Apple TV 4. I thought by all being in the same ecosystem that it’d make things more stable, but that doesn’t seem to be the case. I also own chest straps and hate them, and my watch heart rate is reasonably accurate for me and way more comfortable, so that’s what I want to use.

What’s odd is that I don’t have this issue when using my Apple Watch as a heart rate meter in any of my other workout apps. When I use Abvio’s Cyclemeter for example it “just works” every time between my watch and my phone, so I know the BLE heart rate meter functionality can be setup to work consistently well in a third party app, Zwift dev just has to take the time to do it right.

If you’re reading this thread and want Zwift to fix this, click the Vote button at the very top left. It honestly still won’t guarantee it’ll get into the queue to be fixed any time soon, but giving this issue a higher vote count will keep it on the top of the lists to be fixed when they do check the forums.

Agreed—it’s l somehow even less likely now that it will eventually work and then stay paired. Shameful.