Apple Watch Unpaired Bug

Since I stopped using the companion app on the apple watch I wasn’t getting any activity in Apple Health at all (apple watch wasn’t even tracking my time on the bike as minutes of activity even though I was going hard on the bike for hours), so now I start up a separate “Indoor Bike” workout on the apple watch when I start Zwifting and make sure not to import that into strava so I don’t double count strava km, while my new HR monitor is connected to Zwift directly. I don’t know how it’s ‘supposed’ to work at this point however, maybe someone else does.

Aaron, the better way is to have Health only read the Strava data, whether you’re recording using the watch/Companion or a separate HRM. The trick to avoid double-counting in Strava is to not let it read from the watch–otherwise Health imports the ride from Strava and then Strava sees it as a different file and imports it back. From the Sharing tab in Health go to Apps and then Strava. I have everything enabled except Allow Strava to Read: Cycling Distance. I get one instance in Strava and after refreshing my activities in the Strava app it is recorded into the Fitness and Health apps.

That makes sense, I looked at my settings, and all of them are already set to copy over to strava (including cycling distance which would result in double counting it seems), but also what I was seeing was I wasn’t getting the HR and minutes of exercise for my rides even though they were uploaded to strava. It seems with my settings that ‘should’ have worked correct? Unless there’s something I have to do on the strava side perhaps?

When the companion app was working I would get HR, minutes of activity, and calories in Health, when I switched to my other HR monitor (after giving up on apple watch) I then wasn’t seeing the HR and calories tracked, or come back to Apple Health, which is why I started initiating a separate activity on the watch (which then works but is super kludgy - for instance I forgot to do it today until 10 mins left in my workout, so i got almost nothing in apple health even though the activity was uploaded to strava with all settings in health set to enable for strava).

Edit: I accidentally deleted the post when I was trying to edit it. Sorry about that.

Huh, I’m not sure what is going on there if the settings look correct. I use AW or a Scosche HRM and everything is pulled into Health either way. I think Strava is an off/on setting: you’re either sharing all data or nothing when you give access, so it seems like a setting on the Apple side. All I can think is to start over: stop sharing on both sides and then connect again?

January 22 update has nuked the ability to pair at all for me (I am on reportedly supported equipment / OS) - despite all of the fiddles.

Hope the fix is near. Super frustrating.

So, I found that it is copying the ‘minutes’ over to health, and I see the ride in the list of activities, but it doesn’t seem to copy calories (the red ring on the watch) even though in the individual activity you can see the calories. So for today I had a ride that was 998 calories, which shows in the activity list, but the red ring (calories) doesn’t show those calories. The only way I seem to get that to update is to record the actual indoor ride on the watch.

Did you get any response/solution? It’s a waste of time to read similar complaints. We need a solution. This problem has been lingering for more than 2 years.

The response is essentially “we know Apple Watch does not work, we’re working on a longer term solution, but for now they are pulling the companion app from the store”…

Here is what they said:

Additionally, for Apple Watch owners: we are aware that this experience needs upgrades and we are working on a longer term vision for support. In the meantime, the Zwift Game and Companion apps will be removed from the Watch App Store.

This is from the following thread: Upcoming Changes to Supported Operating Systems [December 2021]

I’m not trying to defend the current state, but because I do want to get active energy credit for rides in Apple Fitness, I tried again to get it working. The good news is it will work sometimes following the steps and checklists frequently laid out. (Closing and restarting the watch app, turning Bluetooth on and off, turning on theater mode, restarting devices). Sometimes it works from the get go. Other times it takes 5 minutes of fiddling. or never. I wouldn’t give up hope that it’s possible to get it running as is. I do hope Zwift will make an effort to try again as a lot of us really want this to work, love Zwift, and for me at least this is the only part of the experience that is not excellent. Please let us know if we can beta test or otherwise help get this on the roadmap.


My last thought is that it could be a privacy setting in Strava, since the calories may need heart rate data to be calculated. In the Strava settings there is a Data Permissions tab, which for me says I have allowed access to Health-Related Data, “like a heart rate monitor.”

What worked for me:

  • remove Zwift (not Zwift Companion) from Watch via watch app on iphone
  • connect all devices to zwift via companion app on iphone to PC running zwift.

Theatre mode worked for me today :slight_smile:

Spoke too soon. Didn’t work the third time :roll_eyes:

This does not fix the situation of needing to restart companion app on phone/watch multiple times to get the pairing to stick.

Honestly, I just wish they let us plug in IP addresses from the companion and watch apps for the iPad/AppleTV/or whatever. Make it a ‘developer mode’ or something but I purposefully run static DHCP so I always know what device(s) are. Probably makes me an IT snowflake but at least I could punch it in.

Post 1.22 update (not sure if that matters!) finally got it consistently working on both the wife’s apple watch series 6 and my series 3!
Iphone12 and apple tv with kickr for equipment.
Same troubles as everyone with unable to pair and dropping out if paired… so…
Same results when closing ZC app. (Spotty results!) BUT… noticed the apple heart rate app was on and closed that one too (side button, swipe left push red X…actually closed every app to be safe!) … viola! Is working consistently now! Open ZC on iphone, open apple watch ZC app, open zwift on appletv. Bingo it worked! (Multiple times on both watches!) no drop outs since!
*one note: if running zwift on iphone (we do this when both of us are riding together… wife on appletv, me on iphone) open ZC app on watch and iphone, then open zwift on iphone, pair it again inside zwift before starting your ride and it should pair consistently!
Hope this helps and maybe fixes it enough that people can enjoy zwifting again! (And zwift can keep this app on apple watch!)


I have spent too much time with level 1 tech support…this is more useful than anything I have gotten from them. I can’t understand how this is so hard when Ride w GPS does it without fail, no need to do anything. It Just Works™. I’ll review this when I ride next but it’s hard to justify paying for something that works intermittently.

Thanks Marc! This solution worked for me! (After I basically tried everything else suggested out there!!)

This worked great for me, only difference is I am running Zwift on my MacBook Pro.

Essentially I:

  1. Uninstalled the “Zwift” app from Apple Watch so only the “Zwift Companion” App remained ( not sure this makes a difference )
  2. Closed the Apple heart rate app and all other apps to be safe
  3. Opened up all the apps ( Zwift on laptop, Zwift Companion on phone and watch )

And it paired instantly and stayed connected.

Hello everyone, same as me.

I have some trouble to pair my Apple Watch 6 series to Zwift Companion, to ride with Zwift on my Ipad.
All my devices are connected to my home Wifi.
On the watch, I see “unpaired” then sometimes, “pairing” but oftenly, nothing appears then, and sometimes, hear rates is sync with Zwift, but cut every 10 seconds.

I read that we have to close “apple heart rate” apps on the watch, but on my case this app is never open on my watch, and I have still the issue.

It’s super FRUSTRATING because that happen at the beginning of a ride (mostly workout, less free ride), so i’m not focus on my workout and I do bad exercices.

Details of my devices and apps :

  • Apple Watch Series 6
  • Apple iPhone X, iOS 15.5 model number NQAF2ZD/A
  • Apple iPad Pro 12,9", 3rd generation, iOS 15.4.1, model number MTFL2NF/A
  • Zwift Companion (on my iPhone), version 3.36
  • Zwift (on my iPad)
1 Like