Apple Watch Unpaired Bug

Alpha- functionality may not work.
Beta- largely works, might have minor issues or unknown crashing bugs.

This functionality is alpha software. Definitely not beta.

1 Like

Zwift killed Apple Watch software in the last client update. I realize that maybe not a lot of people use their Apple Watch as a primary HRM, but we did have Alpha functionality at best, so it’s no loss. I’d given up on this some time ago.

1 Like

Ugh, I guess I am not alone with this issue. I wrestle each time I use zwift…sometimes I get lucky but more and more it DOES NOT work. I will be looking at other smart ride software that works with my apple watch I guess.

Hello all…glad I found this thread but I suppose still no resolution.

My trouble is that I’ve just upgraded to a new iPad Pro 12.9in to use in my trainer setup. Everything works perfectly.

I’m out of town and wanted to run on hotel treadmill and tried to pair AW 6 to Zwift for HR and run speed but had no success getting it paired.

The AW does pair to the Zwift app on my phone but only after installed the Zwift App on my AW.

I’ve done this before on an older iPad Pro in the past so unsure what exactly I’m doing wrong.

Any solution? Here it’s been very unreliable, sometimes works, sometimes not, but for a while now it never works. So frustrating…

See the update on Apple Watch support at the end of the initial post at Upcoming Changes to Supported Operating Systems [December 2021]


1 Like

Same exact thing happens on my end.
In fact, it used to pair better a few months ago. Now I have to go through a voodoo ritual to get the watch to pair properly. So frustrating.

Either fix the problem or don’t make it available at all so that we can move on.

I don’t mind buying a separate item but I’d rather not if I have a perfectly good smart device that can do the job.

Yeah, it frustrated me too… When they took the companion app out of the watch store I think that’s their version of “don’t make it available at all”. No new customers can download it to their phone, so I bet they wanted to not swipe the rug from people who already have it “sorta working” by just pulling it from the watch store. On the positive side for me I did use it in its “sorta working 1/5th of the time” state until my new HR monitor came in, and my new one pairs 100% of the time so far… fingers crossed

It would have been much better for me to keep just using the apple watch I had of course. I will feel dumb if they fix it in the next month or so, but I didn’t want to bet on a quick fix given their comment of “long term vision” for the fix, which sounded like more than making white deer the correct color.

Latest Zwift companion update advised that future new installations of the app won’t include the watch version of the app, so only those that had it installed already are able to use it.

On the support document for HR monitors, it says that using the apple watch as a HR monitor is required for Zwift Companion to be able to add workout data to Apple Health. Now that this watch app is no longer supported, is this part of the support document still true?

Since I stopped using the companion app on the apple watch I wasn’t getting any activity in Apple Health at all (apple watch wasn’t even tracking my time on the bike as minutes of activity even though I was going hard on the bike for hours), so now I start up a separate “Indoor Bike” workout on the apple watch when I start Zwifting and make sure not to import that into strava so I don’t double count strava km, while my new HR monitor is connected to Zwift directly. I don’t know how it’s ‘supposed’ to work at this point however, maybe someone else does.

Aaron, the better way is to have Health only read the Strava data, whether you’re recording using the watch/Companion or a separate HRM. The trick to avoid double-counting in Strava is to not let it read from the watch–otherwise Health imports the ride from Strava and then Strava sees it as a different file and imports it back. From the Sharing tab in Health go to Apps and then Strava. I have everything enabled except Allow Strava to Read: Cycling Distance. I get one instance in Strava and after refreshing my activities in the Strava app it is recorded into the Fitness and Health apps.

That makes sense, I looked at my settings, and all of them are already set to copy over to strava (including cycling distance which would result in double counting it seems), but also what I was seeing was I wasn’t getting the HR and minutes of exercise for my rides even though they were uploaded to strava. It seems with my settings that ‘should’ have worked correct? Unless there’s something I have to do on the strava side perhaps?

When the companion app was working I would get HR, minutes of activity, and calories in Health, when I switched to my other HR monitor (after giving up on apple watch) I then wasn’t seeing the HR and calories tracked, or come back to Apple Health, which is why I started initiating a separate activity on the watch (which then works but is super kludgy - for instance I forgot to do it today until 10 mins left in my workout, so i got almost nothing in apple health even though the activity was uploaded to strava with all settings in health set to enable for strava).

Edit: I accidentally deleted the post when I was trying to edit it. Sorry about that.

Huh, I’m not sure what is going on there if the settings look correct. I use AW or a Scosche HRM and everything is pulled into Health either way. I think Strava is an off/on setting: you’re either sharing all data or nothing when you give access, so it seems like a setting on the Apple side. All I can think is to start over: stop sharing on both sides and then connect again?

January 22 update has nuked the ability to pair at all for me (I am on reportedly supported equipment / OS) - despite all of the fiddles.

Hope the fix is near. Super frustrating.

So, I found that it is copying the ‘minutes’ over to health, and I see the ride in the list of activities, but it doesn’t seem to copy calories (the red ring on the watch) even though in the individual activity you can see the calories. So for today I had a ride that was 998 calories, which shows in the activity list, but the red ring (calories) doesn’t show those calories. The only way I seem to get that to update is to record the actual indoor ride on the watch.

Did you get any response/solution? It’s a waste of time to read similar complaints. We need a solution. This problem has been lingering for more than 2 years.

The response is essentially “we know Apple Watch does not work, we’re working on a longer term solution, but for now they are pulling the companion app from the store”…

Here is what they said:

Additionally, for Apple Watch owners: we are aware that this experience needs upgrades and we are working on a longer term vision for support. In the meantime, the Zwift Game and Companion apps will be removed from the Watch App Store.

This is from the following thread: Upcoming Changes to Supported Operating Systems [December 2021]

I’m not trying to defend the current state, but because I do want to get active energy credit for rides in Apple Fitness, I tried again to get it working. The good news is it will work sometimes following the steps and checklists frequently laid out. (Closing and restarting the watch app, turning Bluetooth on and off, turning on theater mode, restarting devices). Sometimes it works from the get go. Other times it takes 5 minutes of fiddling. or never. I wouldn’t give up hope that it’s possible to get it running as is. I do hope Zwift will make an effort to try again as a lot of us really want this to work, love Zwift, and for me at least this is the only part of the experience that is not excellent. Please let us know if we can beta test or otherwise help get this on the roadmap.


My last thought is that it could be a privacy setting in Strava, since the calories may need heart rate data to be calculated. In the Strava settings there is a Data Permissions tab, which for me says I have allowed access to Health-Related Data, “like a heart rate monitor.”

What worked for me:

  • remove Zwift (not Zwift Companion) from Watch via watch app on iphone
  • connect all devices to zwift via companion app on iphone to PC running zwift.