Apple Watch disconnect issue

Sorry to hear Zwift is giving you some trouble Scott! Are you able to turn off your Bluetooth/place your Watch in Airplane mode after Zwifting?

Hi,

I’m having the same problem (I think). The Zwift app keeps restarting on the watch, even if I have forced closed on both IPhone and watch. Tried turning off bluetooth, and rebooting both devices. Only thing that worked was to uninstall/install Zwift on watch.

Any advice? :slight_smile:

//Caisa

1 Like

Thanks Vincent, I suppose I could but then my watch won’t connect to my phone for everything else.

I starting having this issue, too. Started about a week ago. I end my ride and the Apple Watch stays connected and displays “in game”. I’ve tried rebooting the watch, killing the apps on the watch, iPhone, and iPad and it still stays connected.

Also having same issue. Disappointed that it is still not resolved after a year. I did a temporary fix by powering off and on the Watch.
It seems to only be a problem with the Zwift app although Zwift say lamely: I am so sorry for the inconvenience, but at this moment there is nothing we can do as it is an Apple tech issue. And for further information you can reach out to Apple and let them know issues with the software.

Zwift have been aware of this issue for at least 2 years https://forums.zwift.com/t/apple-watch-2-not-working-correctly-and-not-turning-off/2606/2

Same thing started happening to me today. I had to restart my watch to stop it.

1 Like

This happens to me from time to time as well. Last night I had to manually shut off my watch in order to get it to disconnect … and of course in the process that meant that my ride was never recorded in Activity. Brilliant.

Zwift likes to put the blame on Apple, but it has nothing to do with Apple.

1 Like

I only recently experienced this for the first time and, you’re right, my ride was never recorded. I think Zwift’s off-hand response that it’s an Apple issue without any further details whatsoever tells me they most likely haven’t looked into it because there aren’t enough people complaining. I have many other Apple watch apps that don’t seem to experience something like this. Makes me wonder if Zwift really understands how Apple watches and apps function. I think they are the ones who should be reaching out to Apple.

2 Likes

You said it. That is exactly what needs to happen.

In the meantime, we’re just supposed to continue paying for a service that touts connectivity with Apple products, but is highly inconsistent? Really lame.

Also, I have a series 3 watch.

So Zwift expects me to contact Apple about a watch app that sometimes never closes (and I can’t “kill” through Apple’s method to do so on a watch) and therefore causes an issue with the main application. Apple is going to ask me to contact the developer to have it looked into. Zwift knows this. Now if someone on the Zwift development team uses the developer resources at Apple, hey, that’s the start of addressing the problem.

1 Like

On point again!

If by manually closing the Zwift Companion app it still doesn’t kill the connection … that would lead me to believe that it’s actually the Zwift Companion app on the iPhone or iPad that is keeping that connection alive. But then if you manually close down both and it persists … it’s like a “state” of the Companion app is not being properly changed or ended. As a developer myself, this is just basic programming. I’m increasingly irritated by this neglect.

2 Likes

Yes, it’s really strange. I’ve never had an app the can’t be manually killed, especially when the app on the phone is closed as well. I think I had to reboot my watch to kill it. It doesn’t happen every time I ride though. I have a Apple Watch series 3 and an iPhone 7.

It doesn’t happen every time for me either. I had good success doing things in a certain order, but now I think that was just a fluke. I have a Series 2 (getting a Series 3) and an iPhone XR.

Having this issue after my first ride this morning and am disappointed to see this is a 3 year old known but unsolved issue.

1 Like

Having the issue too. Zwift adm will not stand for?

Yep same issue for me.
Started on Friday and drained the watch battery. Still keeps restarting…

Having this issue with my Series 5 watch now. Nothing I do is preventing Zwift companion from restarting. Including force quitting the app on phone and watch and use of airplane mode. Guess it’s a lost cause based on the extensive length of this discussion and apparent inaction by tech support? Too bad - I like Zwift otherwise. There are other options out there.

Problem still there with Apple watch series 5. Anyone found a solution yet?

1 Like

Looking for a solution to this problem and … very disappointing to find a thread that has been around for years. Seems to me that the only way to kill the watch app is a reboot or, if you forget, when the watch is completely drained. What a pain.