Apple TV and Messaging issue

If anything, moving your wife to the 2.4GHz may cause her problems due to more signal interference. But, it should not have any affect on her in game messaging.

Double check that both Apple TVs are updated, that the Zwift apps are updated, that the Companion apps are updated. Ideally, the auto-update does this for you, but I highly recommend manually checking for updates. Since December started, there have been updates for all of the above:

  • TV OS: 5 Dec (ver 12.1.1)
  • Zwift: 7 Dec (iOS ver 1.0.32268) – second update of Dec and probably a different version number for Apple TV
  • Companion app: 18 Dec (iOS ver 3.0.2)

Then force quit everything (i.e., Zwift and Companion apps) on both Apple TVs and phones.

2 Likes

Well FINALLY we have success Alan Lin !! Made sure that everything was updated (her companion app was not) and then force quit EVERYTHING and logged off and back into companion app AND WE ARE GOOD TO GO.

Regards to all.

This is happening to me and it’s messed up my last two group rides when I have been the leader. It would be better if zwift acknowledged the bug rather than us being happy with a workaround that involves force quitting the Apple TV app (which I now know how to do, thanks!). In my case yesterday, after switching worlds to start my group ride, my messages from my companion app came up on the screen as the leader…then as soon as the ride began (the clock counted down to zero) the messages stopped working.

I would not call the need to keep everything updated, force quitting Zwift, force quitting the Companion app, etc., a bug. I would not call “force quitting” the app a workaround. I would call it a “best practice”. You’re dealing with an app that is not designed to run in the background, runs across the internet, needs to maintain connection state, etc… There are a lot of moving parts. If taking the extra 5s to force quit everything after each session is all it takes to keep things running smooth, surely you have 5s to spare.

I always force close the apps on ATV and my iPad (where I run Conpanion) and still have this issue regularly. I would love to understand what causes this, as it really makes no sense to me why it doesn’t work sometimes.

I always do so as well. Even so, I have experienced this problem. However, in over a year of using the Apple TV 4K, it’s only happened like 2 or 3 times. I can accept that sometimes s#$t happens.

Even w/force quitting of the Companion app, sometimes there are network issues (local and/or internet) which can cause problems. To be honest, I think the majority of connectivity issues are user setup issues (e.g., trainer, wifi, bluetooth, computer, Windows, OS X, iPhone, etc…) vs Zwift bugs. No, I am not letting Zwift get a free pass. They have broken stuff w/their updates. They also have many bugs to fix.

I can’t disagree with you on any of that. I just wish I could definitively figure out what the issue is. Perhaps then I could correct it, or at least take some solace in knowing that I can’t. The randomness of it is what bugs me. One of the things I really like about Zwift is that I can have some sense of community on days when I otherwise would be riding by myself. To then not have any chat makes it sort of like being in a group where no one is talking, which is a bit of a downer. Still better than staring at the wall, though!

I had this today on Apple TV / Kickr 18 on an event

  • I did a workout before the event (a warm up).
  • Let it finish, saved , uploaded and then exited back to logon screen
  • logged in , did a just ride for a few mins and then switched to the event when prompted
  • sent a message on the start line and saw it appear
  • no other messages appeared and saw no ride leader messages at the start / whole duration of ride

You really need to force quit both the Zwift app and Companion app to avoid this type of issue. Going back to the logon screen is insufficient. Force quit both apps. Restart. Join your event. This applies to any type of back to back sessions.

Note: If you sign up for an event in advance, you can ride around and a popup will appear asking you if you want to join your event. You can say yes and be taken to your event. Another option is to do your warmup in the start pen.

Hi Lin,

Thx for replying, but I shouldn’t have to force quit just for it to work. With Apple TV this involves a 4 step process with Apple remote with sweaty hands or getting off the bike and doing a power cycle of the Device

Re 2nd point of allowing to join when prompted , have done this in the past but it then records both rides in Strava with the title of the first (ie warmup) ride

All first world problems but annoying

Cheers
Andy

I totally agree you should not have to, but in my experience I find it has eliminated problems associated w/both messaging and also with joining and starting the second back-to-back event. Note, I prefer to exit and come back for a 2nd event unless I do the warmup in the start pen. That “Join” does weird things. No need for a power cycle. Anyway, once you save and return to the logon screen:

  1. Double-click the Home button to bring up the app switcher.
  2. Swipe up and the app will disappear aka force quit.
  3. Restart Zwift.

Note this also solves problems w/other Apple TV apps which become unresponsive and/or if an app or the Apple TV starts running slow.

The other source of problems w/Apple TV Zwift is sometimes a new version has been released. But, the auto-update has not happened yet. As a result, Zwift usually runs, but you end up w/some problems (e.g., missing new route, missing new World, missing new Mission, etc…) So, it’s in your best interest if you hear there is a new update or if something starts acting weird to manually check for an update. The same goes for the Companion app.

~1.5yrs with an Apple TV 4K. The above makes is what makes it 99% problem free!

#firstworldproblems :rofl:

1 Like

I have been having similar problems to those mentioned above. Today I discovered that my either my ATV or iPhone would occasionally switch from 5 GHz Wi-Fi to 2.4GHz Wi-Fi. Although they have the same name, the 5 GHz and 2.4 GHz are not the same network. In my set-up, Zwift Companion will not connect to ATV if I am not using the same frequency and I experience the chat/message issues described in this thread. I hope this helps someone.

If your wireless hardware allows it, set the 5GHz and 2.4GHz Wi-Fi to different SSIDs. Then, make sure your AppleTV and iPhone are only configured to use the 5GHz. This solved Companion app issues for me.