Apple TV 4k remote issues

I have a slightly different issue on the Apple 4k 5th gen with Zwift. The Zwift app does not respond to Up and Down commands issued by a universal remote. Only works with the Apple Touch remote which has already been reported as spotty.

To solve for the Apple TV Touch remote being garbage I went and got a universal remote that works in every other app but not Zwift.

This issue with universal remotes has already been mentioned numerous times in this thread, you could have saved you the money by scrolling through it, reading the posts

@lord02 Truth; thankfully it was a cheap remote.

Quick update on the issue people:

Looks like the update is finally going to happen by the end of next month ( that’s March ). Zwift is due to start internal testing next week. Looks great.

And works super well with ATV, which was the requirement.

That’s it for now, I’ll keep you posted :slight_smile:


Same problem here guys, brand new ATV a few weeks agao. Works for everything else.
I thought it may be the new remote but tried an old style one we had for another ATV in the house. Again not good for Zwift but fine for all else.
Also had some success with downloading and using the Apple remote on my phone.
Glad to hear a fix is coming, seems like a very old thread.

I am new to Zwift and I have purchased a new Apple TV 4k so that I can use Zwift on my television. I am also using the Zwift Companion App on my iPad. I have been very frustrated getting the Apple TV remote control unit to allow me to make any choices on Zwift. The only ride that I could join was the London route. The Apple TV remote controller would not scroll up or down, or to the side :frowning: I spoke to a Zwift tech, and he suggested I try things like going into the Apple TV settings and disabling Siri, and trying different scrolling speeds for the device. That did not work. As a last resort, I decided to do a factory reset on the Apple TV. This option can be found in Settings for Apple TV. The reset worked! Now the device allows me to scroll properly in Zwift. Hopefully I have solved the problem permanently. I hope that this solution works for other people as well.

This is complete horse ■■■■ … no reset will fix the remote. The Zwift app is BROKEN!

Read my last post, long awaited ( more than a year! ) update is coming next month, March to end this misery for us once and for all!

Just for info, I’ve been using an Apple 4K for over a year and although the touch pad could be better, it doesn’t stop me from doing anything, I can move around and select what I want. I might have to try some things a couple of times to get it to land exactly where I want it, but it definitely works.

So maybe a reset might help a bit…

1 Like

True, doesn’t stop me cursing the remote when it won’t play ball and I’m either panicing to join an event before it starts, or trying to sort something out at the end of a race when the HR is through the roof :joy:

Are you a Zwift tester, or what’s your source? This UI update can’t happen soon enough, especially since it’s been hinted at for the last few months :hushed:

No, I’m not a Zwift tester, just a heavy duty user which wants things to work the way they should! Been hammering about this issue for over a year now :slight_smile:

My source is Zwift’s CEO … so I tell the truth my boy


Could this be a workaround ?

Sadly, universal remotes don’t work in the zwift app.

No. I had that confirmed by Zwift Tech Support some months ago before I found this string. After listening to Eric Min on the “Minterview” podcast I posted an only slightly snarky suggestion that the new Zwift hardware unit produce or source an ATV-compatible replacement remote that provides the sort of controls available on PC and Mac.

Thank you for staying on top of this with us. Much love.

It’s the end of March and still nothing… For months Zwift promises (indirectly?) that this problem will be solved… next month!! Covid-19 effect ? not sure, considering the number of events produced at the moment and the means implemented to support the double of Zwifter regularly connected …

Hi everyone!

Maybe some of you have noticed that Zwift just got updated.
It does NOT include the updated UI, but they’re in the final stage of testing the next update, which is huge and DOES include the UI Update. It’ll be release “next couple” of weeks, guaranteed in April 2020.

Just wanted people to know since I’ve been waiting for this for ages … and I know some of you are eager for it as well.


1 Like

Exactly what I said previously :smiley:

ZHQ decided that with up to 34,000 concurrent users that this wouldn’t be a great time to release the UI. Hard to fault that, seeing as there’s a fair amount of graphic stutter on some rides. I want this badly, but the system is stressed. I want a TVOS UI update very badly because I hope it will my my jobs (yes, plural) as a ride leader easier. When I see that 16-22,000 concurrent riders is the average for the European afternoon and evening, I’m pretty sure that releasing the update is a recipe for disaster.


Zwift has still not had the time to update/fix the UI for AppleTv devices … most probably postponed to August 2020 :frowning:

How can Zwift say they don’t have TIME to do an update. That is ridiculous. They have 100,000’s of users worldwide waiting for these updates to make things work better. Who is their beta group? How do I get on that list?

At $15/month they damn sure ought to be about to FIND TIME to get an update out. That is only a cool $1,500,000 per month in revenue per 100,000 users.