Apple TV 4k remote issues

(Eiki Egilz) #81

@Vincent I see you’ve just released an updated iOS version, 1.0.31648, but I still can’t turn off the title music ?!?!
also, can I turn on “shadows” on the Apple Tv 4k, is that an "high end iOS device?

*1.0.31648 - just upgrated to this version, but see version below, in bold

Nov 13, 2018

• Added full screen support for new 2018 iPad Pro lineup
• Fixed bluetooth issue that could cause loss of control of smart trainers
• Added shadows to the graphics on select high-end iOS devices

  • 1.0.31304

Oct 29, 2018

• Fixed issue where users could get stuck going in circles
Added music toggle to title screen <— why is this not supported in the menu of Apple Tv 4k ???
• Fixed ‘Ride With…’ feature on NYC map
• Other bug fixes

For now I just put the volume to minimum for, “Game Sound Volume” but then I don’t get any sound when pushing buttons etc … but at least I get rid of the menu music

No toggle to switch the title music off, in my settings:

(Vincent) #82

Thanks for the heads up! I’ll inquire with our team.

Edit: No updates

(Eiki Egilz) #83

@Vincent thanks! please let me know when it has been implemented

(🚴🏼‍♂️) #84

The issues you commented on, exactly the same issue on ATV. I’ve given up trying to use it, just to much of a hassle. I’m using my laptop now, which in the next year to eighteen months the graphics will be out of date as it’s not a high end PC.

(C) #85


Can you clarify what is meant by “down the pipeline”?

Is this a feature that “may come to a future version for Apple TV” or is this actively in the App-store roll-out channel?

In either case: timeline?

(Kevin Bartlett) #86

YOU ARE A GENIUS!!! I have been getting so frustrated with this, having to force a shutdown, when restarting Apple TV, and opening Zwifit I would have to save the ride, (because the cursor wouldn’t move to allow me to end my rides). I was then having to log into to download the fit file and upload it to Garmin and Strava…It was becoming such a waste of time and extremely inefficient. Thank you for giving me 20minutes back in my day!!

Can't scroll left while reviewing workouts in training plans - atv4k
(Eiki Egilz) #87

@Vincent hey man :slight_smile:

Are there any news on these two issues, the first one being MUCH more important?

01 - The ATV 4k remote issues, which started this thread all along and I posted a video and numerous users in here have reported the same.

02 - Added music toggle to title screen <— why is this not supported in the menu of Apple Tv 4k ???


(Vincent) #88

Hey Eiki, we’re still investigating! Might be an obvious statement but make sure the battery in the remote is charged as well.

As for the ATV music toggle, no word on an update for that.

(Eiki Egilz) #89

@Vincent hmmmm “investigating” … are we still at the level that you say you’re not able to re-produce the problem inside ALL your lists within the UI of Zwift? You see all the people who report the same problem … easiest lists to check is the “customize” list where you choose your gear/bikes/socks etc …

But to address your comment, my remote is 100% charged and has nothing to do with this, it works PERFECT in all other apps inside the ATV4K.

Zwift Game Release: Dec 3, 2018
(🚴🏼‍♂️) #90

That feels a bit like telling my grandmother how to suck eggs.

Given level the of feedback, it might be better to acknowlwdge the issue, and attemptiing to resolve it. People have bought ATV for Zwift as an easy and cheaper option. The later point is true, easier it is not.

There is even video on this thread, demonstrating very well the issue.

Please do better.

(Eoin Winter) #91

Using Apple TV 4K with charged remote battery :point_up: as well. Still have the problem …

(Maarten Van Heide) #92

Hello Vincent,

I have the same issue. I just installed Zwift on the apple tv, 4th gen, 32GB, and moving the cursor/scrolling is not possible at all. Battery of remote is fully loaded.

It works fine in every other app. I programmed another remote for the apple tv and tried again, same issue. Also tried controlling with iPhone, also same issue.

Only thing left is a software bug in the Zwift app. Apparently it does not pick up the inputs from the Apple cursor movement.

Do you have any idea when this will be fixed ? At the moment I can only do free ride.


(Maarten Van Heide) #93

After reading one of the other comments: I switched off the voice over, now the cursor can move again. It still is not smooth but at least I can get it to work.

(Eiki Egilz) #94

Please upvote this problems guys, it’s at the top of the thread … so Zwift will actually start to fix this issue!

@Vincent have you reported and escalated this problem properly inside your company? This should have a really high priority since people all over the globe are using Apple Tv 4k for Zwift …

(Ben Cook) #95

It’s not just the 4k. I’m having the same issue with my 4th. Zwift is unusable.

(Matthew Merz) #96

I am also experiencing this problem. So much so that I was unable to end my ride the other night for quite some time. @Vincent - Let me know if you need any info from me.

(Eiki Egilz) #97

@Vincent do you have any news on the issue at all? Are your developers working on fixing the remote control issue on Apple Tv 4k?

(Vincent) #98

@lord02 @Matthew_Merz @Ben_Cook1 @Maarten_van_Heide @Eoin_Winter @Greying_Cyclist

I was able to reproduce the UI delay as I mentioned on the 9th and the Apple TV team has been made well aware of this. I’ll give you all updates in real time as usual although I have no significant update at this time. Sorry for any inconvenience and thank you for being so patient with us!

(E) #99

The issue persists after yesterday’s ‘big’ update. Too bad this hasn’t been fixed. Zwift - Please make this a priority,

(Matthew) #100

Scrolling through workouts is a pain, but selecting and changing your FTP with the Apple Remote is downright impossible.

Even the tiniest touch causes the FTP to shoot up or down. You want 120 watts? Nope…you get 109 or 143. Your only hope is to try to get to 150 and then gently touch it and hope it jumps to near 120.

Then, when you try to move off FTP and back to the workout, you’ll most likely accidentally change it again while trying to move off.

If you can’t fix the crazy responsiveness of the touch pad, at least make the FTP a field you have to click on to change, then click on again to lock it in place.

I’ve been doing workouts at random FTPs because I’m afraid I’ll never be able to get back.