ANT+ RXfails every 3.5 mins?

Hi all,

I’m having an absolute nightmare with ANT+ drops causing loss of power in races and loss of ERG in workouts. Obviously this is a complete disaster for my wifes racing this season.

Below are the results from 3 different trainers:




Background:

I have 2 Lindy active USB extensions cables and 2 Wiggle Lifeline ANT+ dongles. I have tried all combinations of dongles and cables literally 20mm away from the antenna location on the Wahoo Kickr and also under the bottom bracket. - No difference.

I have tried 4 different turbo trainers:

Kickr’18 X2 - Both the same ( that’s the one in the photo).

Tacx Flux 2 - Absolute nightmare. Really really bad, average 13% RXfails.

Kickr V5 - Only used once and never failed however loggile on Zwiftalyzer looks exactly like the one pictured.

I have tried 3 computers:

Dell Optiplex 7010 SFF

Dell Precision 7530 Workstation Laptop

Dell Optiplex 9020 Mini Tower

All show the same logfile trends…

I have a PCIE dual powered 0.9amp USB3 adapter card on the way. NEC chipset. I have also purchased 2 Lindy 3m USB extension cables. Not active ones but allegedly triple shielded.

The only other items are a Wahoo Climb and Headwind. Unplugging these doest make any difference to the signal. WiFi is on channel 2, no microwaves in the vicinity.

I have a Polar H10 HRM. Tried it in BT and ANT+

I just can’t get on top of these random drop outs. Why is there RXfails every 3.5 minutes, is that a polling thing?

Any pointers on the screenshots would be greatly appreciated

Pretty well known on Wahoo devices, I believe it’s internal overlap of the ANT+ and FE-C broadcasts. It’s worth noting that you’re not getting drop outs according to those log files, or you’d have multiple searches.

On the Flux 2, the trainer appears to be paired to Zwift twice. Ensure it’s using FE-C for everything, because it looks like one of the three is legacy ANT+, which probably doesn’t help. In fact you can disable standard ANT+ completely in the Tacx app. I do this on my Neo 2T, I believe the Flux 2 is the only other device that has the functionality.

Thanks for the reply Dave,

The Tacx was a loaner so thats out of the equation now. Interesting that it was using the old protocol though.

This is basically what happens pretty much every day, the screenshots are a race that my wife done 2 days ago. Needless to say she fell out of the draft with the end in sight !

Zwiftalyzer logfile:

Zwift post-ride analysis ( power only):

Zwift post-ride analysis ( all sensors ):

So, you can see that everything apart from heartrate lost the blob near the end of the race. We have tried HRM straps & watch on ANT+ and BT as well. Just in case the HR signal was having an effect.

Maybe i’m not grasping this but looking at the Zwiftalyzer report, it was the HR that was the issue yet it was power / cadence / speed that dropped ???

Yeah that’s definitely worse. What’s weird is that in isolation, those RxFail percentages aren’t bad at all. Have you checked the power options in Windows? It’s worth disabling USB selective suspend, and also preventing Windows powering down the USB hub - this is done via Device Manager.

It’s already done Dave. Its on the Maximum Performace powerplan with the correct advanced options ticked. I have checked the BIOS for anything that could be at fault but no dice.

I have even swapped out the standard dell PSU for a 750w Corsair modular one.
All i’m powering is a Geforce GTX1650 LP card so the PSU is way overpowered for what i need.

I have literally just fitted the USB Transcend PCI-E card 30 mins ago which has a dedicated Molex 5v supply off the modular power supply.

I have just scanned all the surrounding WiFi channels directly beside the Wahoo Kickr. The 2 strongest signals are mine. One access point in the garage ( where everything is set up ) which is used for the Zwift companion app on our phones and the other is the house. The main PC running Zwift is ethernet back into the home via underground duct.

Edit:

“and also preventing Windows powering down the USB hub - this is done via Device Manager.”

You may be on to something there…

Update;

I had overlooked the power managment settings in device manager so changed them.

With high hopes I done a quick 30 min ride in ERG mode and then this happens:

Yet the log file shows:

At this point I dont know if the trainer didnt transmit back to the PC what the wattage value was when that happened or it was a receive issue, even though the logfile would suggest otherwise.

So the HRM didn’t drop, Zwift didn’t record a drop, but the Kickr just randomly stopped sending power data for a second? That doesn’t seem right.

Yes it seems that way. It’s a 3 day old factory refurb warranty replacement. To be honest, the old one displayed the same behaviour and had roughly the same average RXfails during a workout.

I’m using an iMac 27" as my Zwift platform together with a Wahoo KICKR V5.

I had dropout issues with this setup and it didn’t matter if I used Bluetooth or ANT+. With ANT+ I could at least plug the dongle into a 3 m shielded USB extension cable and try different locations.

I read multiple threads about the issue, and watched several Youtube videos as well. I tried various dongle locations and was at first getting 20-30% rxFail rates on average. At its worst, I was getting around 40-60% rxFails on the KICKR channel, which obviously caused dropout issues.

One thing I noticed for the KICKR V5 is that placing the dongle somewhere on the left gets a significantly better reception compared to the right.

I managed to get a 3-4% rxFail rate by letting the dongle hang freely in the air (as opposed to on the floor). I simply put the end of the cable on my wife’s e-bike saddle and let the dongle hang over the side a bit. It’s hanging roughly at the same height/position as my drop-bars and about 80cm to the left of my bike/trainer.

I was previously getting multiple power dropouts on every ride. Most of the time it came back automatically after a few seconds, but sometimes it never came back and I had to go the pairing screen and unpair everything, and then pair all devices again to be able to resume my ride.

Now, with my hanging dongle :wink: as described above, I haven’t had any problems for about a week. Last weekend I went on a 104km Watopia ride, and didn’t get a single dropout. Hopefully this will be the end of my dropout woes.

One thing I still notice by looking at my rxFail logs is that there’s an rxFail spike exactly every 3.5 minutes. It’s not enough to cause any issues, but I find it interesting that the OP mentioned the exact same timing. Maybe its a Wahoo thing…