Another Windows 10 not loading issue

Hi, I hope that you are all well.
I have seen a few similar issues and tried several ‘solutions’.

I have been a Zwifter for several years, during my ride with Geraint last week a knocked over cup of tea terminated my laptop.

I am now trying to load Zwift onto another, more modern PC with Windows 10.
I have downloaded the app.
When I open app and click on ‘let’s go’ , after 5 seconds screen returns to desk top.
Please help.

Do you have .Net 3.5 enabled on the Windows 10 compute?

Open Control Panel>Programs and Features
On the Left-Hand side click on Turn Windows features on or off
Make sure that .NET Framework 3.5 (includes .NET 2.0 and 3.0) is checked

Restart you computer and then see if Zwift opens.

2 Likes

Hi @Martin_Hedley_CLS_B, have you tried looking into your display settings? I found that on my laptop if the display is set to 100% scaling then Zwift won’t open, I have to put it at 125%.

image

2 Likes

I have tried 100% and 125% .
No difference.

1 Like

NET 3.5 Checked.

I’ve had that when I had many other programs running and Process Explorer said memory was almost all used up.

When I close everything else, especially things that throw up notifications and pull focus away from Zwift, it runs fine and never cuts out on me.

Try that and see what happens … :biking_man:‍♂:+1:t3::sunglasses:

Is your windows 10 fully patched to 1909? (just an easy way to eliminate any other issues) Are you using Antivirus and if so what? Possible it is blocking the process for updating with a false positive. (logs in AV should show that)

1 Like

DX DIAG report shows "there is a problem with Microsoft Basic Display Adapter error code 31

https://answers.microsoft.com/en-us/windows/forum/all/microsoft-basic-display-adapter-code-31/49ae1d31-db66-4d5c-b0e1-eb3704ba53dd

2 Likes