Android Supported Devices (UPDATED: March 9th, 2019)

(Nenad Stajic) #141

Hi currently using Samsung Galaxy S8. Having issues pairing Milestone Pod. Under search it doesn’t come up at all. Tried restarting everything still nothing. Tried with iPhone found it instantly.

How can android zwift pair up my milestone pod?


(Mike.Gong Fullerton.Bikes) #142

Sharing my experience so far…

My success rate for the recent Beta release has been around %60 or so. For context, I mainly use the running module at Gym on the treadmill. My one time using it with my Tacx trainer at home resulted in a crash 1hr into the ride and lost all my data, so I’m skeptical to try it again.

While at the gym, I have trouble getting my Milestone Footpod and Scosche HR band to pair. This seems to only happen when the gym is busy and there are a ton of BT devices transmitting. During slower times, my devices seem to pair faster. At home, they pair pretty fast. I don’t think this related to the Samsung Tab S4 I’m running it on, as my Pixel 2 performs the same way.

Recently I’ve also experienced dropouts in SPM on my milestone footpod. Re-pairing it seems to solve the issue, but that process can be painful under the conditions stated above.

A couple of time I’ve spent 20mins at the gym trying to get it to pair, and then end up giving up and just running.

Could it be related to BlueTooth 5.0 @Vincent

(Tom Reynolds) #143

I have an Nvidia Shield K1 tablet that I’d like to run Zwift on. It should have the ability but the App Store says “Your device isn’t compatible with this version”. Is this indefinite?

(Pieter Brankaer) #144

Running this on a Oneplus 2. Seems to working fine. Framerates aren’t super, but it’s enjoyable enough. No ant+ yet (I know, not actually supported anywhere).

(Athir Ayoub) #145

Installed and ran Zwift on my Pixel 2 XL flawlessly, paired to my Tacx Flow Smart trainer and Wahoo Tickr HRM.

I did a 1-hour ERG workout, and actually found the process of loading the app, pairing to my devices, and syncing to Strava significantly faster than the Windows 10/i5 laptop I was running Zwift on before that!

I have a set of Stryd foot pods coming, will attempt a run using the Android app, and post my findings.

Thanks for the port, guys!!! It’s looks awesome so far, but I’d like to see more support for tablets. As flawless as it ran on my Pixel 2 XL, it was tough to make out everything on the 6" screen even though I had my phone mounted to my stem.

(Tobi Onassis) #146

Huawei mediapad m3
Worked until the day before yesterday.
Since the new update it says something like “data vilidiation error” and “attempting to download zip”
Deinstallation and reinstalling didn’t work.

(Jason Bye) #147

Just tried on an Xiaomi MI A2. The game only shows in shades of red. All the banner and popups and lists and everything that appears over the top are fine, but the actual game video is in reds and blacks only.

(Jack) #148

I have a Huawei Mediapad M3 Lite. Still works for me, granted it is a different tablet entirely. Hope you manage to solve the problem.

(Denis Carraro) #149

I have a Xiaomi Redmi Note 3 Pro and I’m just getting the Zwift blue screen which says data validation failed? Can anyone tell me what this means as I thought that it would work ok with the Xiaomi Redmi Note 3 Pro!

(Tom Den Ouden) #150

Downloaded the app on my Huawei P20 Pro, works perfectly! Did 3 rides so far.
I did have a bluetooth drop yesterday but everything else went well :slight_smile:

(Frank Naro.) #151

Huawei mediapad M3 Lite zeigt nur einen schwarzen Bildschirm

(Martyn Reidie) #152

Is there an android device that will be like Apple TV? I’m currently exploring options for casting to a TV from a phone but if there was an alternative to Apple, I’d be sold.

(M Herman (Am Ani Z)) #153

I’m using Oneplus6 with Oxygen OS 9.0.2. No option to pair my Wahoo HRM & it seem like it not able to detect my Milestone Pod. From Bluetooth phone search I’m able to find the pod, but not from Zwift app.

(Mk) #154

Hi, same here…
At the end of August/beginning of September it was no problem to connect my Milestone Pod and a heartrate-strap with zwift android beta on my p20pro. Today I couldn’t connect the Pod. I tried everything. For the hr-strap there was no option to connect at all. Please fix the bugs as soon as possible. Without zwift running on the treadmill is no fun! Greetings!

(Jack) #155

Xiaomi Mi Max 3, Global Edition. 4/64GB, MIUI 10, Android 8.1.

Before the Halloween update, zwift wasn’t working…it starts up and when I finally get to riding, the background and avatar is just a black screen, while the data screens on the left and right with the other riders data and wattage screen is visible and working fine. After the Halloween update, still the same on Watopia course, but when New York came around, the background and avatar works, only everything was in a red hue. Hoping it will improve in the future.

(Clive) #156

another +1 for Nvidia Shield and Shield K1 tablets support… I’ve two and await to use this investment

(Micah) #157

+1 on custom workouts on Android. Even if just the ability to drop in the .zwo files without the UI to create them.

(Zoran Patheria) #158

Can you please add support for galaxy tab s2 9.7 inch? It has almost same specs as the s7 edge and zwift runs really well on it.

(Tony Paez ZHR (D)) #159

I have a Motorola G6 Plus - latest version. I do not see the Zwift Unreleased app to download from the Playstore.? My 4 y/o Lenovo tab 3 downloaded it fine. How can I get this on my G6 Plus?

(Andrei Yushkevich) #160

Xiaomi Pocophone F1
runs well with 6/64GB, MIUI 10, Android 8.1.