Android Companion is not available since 3.34

Companion issues:
open then freeze at “Z” logo blue background screen,
occasionally can access to login screen, but can’t login.
after try to login, top progress bar keep rolling but App can NEVER jump into main interface.

At least you can add error reporting dialogs, let user know what happened?

install by APK, download source: apkpure.com

location: CHN Guangzhou city

tested cellphone OS: android12 & android10

tested Companion android vers: 3.34.0, 3.34.1, 3.35.0

Last working Companion android ver: 3.33.0, 3.33.1 released in March

iOS Companion(latest ver3.35.0) on the iPad is working fine.

Earlier than v3.34.0 already not available, enforce users to upgrade Companion.
It is the first time I met android Companion not working properly.

CHN android phones don’t have Google Framework(Services) components or Google App Store, and here have network blockage, tried VPN, it didn’t worked.

refer to Alan’s posted

I’m guessing it’s because ZWIFT had changed Login connect detection & config

Absolutelly the same problem. Android 10.
Tried to clean cache and data. Infinite runing stripe.
Huawei smartphone without Google-services.
Tried VPN.

1 Like

Same here; even reinstalled, either it sits on a blue screen, or after reinstalling, it won’t log in, just “loads”

app was working just fine yesterday.

1 Like

Andrew, did u update companion from google app store?
no offical reply, i think root of the problem could only guess by ourself,

Basically I guess it is becos new ver need google service connected normally

1 Like

No this was also through APK for a Amazon Fire tablet.

But again, have never had this issue before yesterday.

All here with this problem not using Google services and it began with 3.34.x branch apk.

1 Like

Same issue with Huawei smartphone. It works well before 3.34.x. Any progress ?

1 Like

it has to be without Google Sevices installed in our phone. that talks the differences, few players reported such problem like us.

I have Google Services installed in my phone , and update companion version from 3.33 to 3.34 in Google Play. But it still broke.

2 Likes

Same problem. Custom AOSP without google services, login page doesn’t move to next.
Attached logcat:

2022-04-27 11:13:33.907 11578-11578/com.zwift.android.prod E/Event: Could not dispatch event: class com.zwift.android.ui.event.GameInfoInitializationEvent to subscribing class class com.zwift.android.ui.activity.LoginActivity
java.lang.NullPointerException: Gson().fromJson(firebase…ersionUpdate::class.java) must not be null
at com.zwift.android.services.RemoteConfig.m(SourceFile:1)
at com.zwift.android.app.UpdateManager.j(SourceFile:1)
at com.zwift.android.ui.activity.LoginActivity.onEventMainThread(SourceFile:5)
at java.lang.reflect.Method.invoke(Native Method)
at de.greenrobot.event.EventBus.f(SourceFile:1)
at de.greenrobot.event.EventBus.e(SourceFile:5)
at de.greenrobot.event.HandlerPoster.handleMessage(SourceFile:9)
at android.os.Handler.dispatchMessage(Handler.java:106)
at android.os.Looper.loop(Looper.java:193)
at android.app.ActivityThread.main(ActivityThread.java:6796)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:917)

please give us a fix!

4 Likes

3.35.0

Still can’t use the app, still completely blue screen for me.
This is getting mildly frustrating nobody at Zwift can even admit there’s an issue.

3 Likes

Confirm no changes with new 3.35.0 version.

1 Like

updated to 3.35.0, still not work

1 Like

Still not working! Pleas fix it

2 Likes

FYI, after emailed Zwift support team,

I interpret that reply as “those devices without Google Mobile Services-GMS/Google Play Store, won’t be supported anymore”

There is NO coming a fix, it even not a bug, they just changed remote login config, denied Companion login without GMS

Salute to ZW

1 Like

Meanwhile I thought it was kind of funny, last night I was able to use one of my tablets that cannot for some reason run Companion App, ran Zwift itself totally fine without issues.

Doesn’t even make sense to me.

1 Like

This is exactly what’s happening with my Hammerhead Karoo 2.

1 Like

Was shocked Zwift Companion worked even on bicycle computer :0
But saw it by own eyes.

Won’t in a few months.

The companion apk 3.34 and 3.35 installed from google store are both freezing at blue Z logo page. It was able to use before those updates.

2 Likes