Android app not controlling Kurt Kinetic R1 Direct Drive - SOLVED

Rouvy controls my kinetic r1 trainer just fine. Kinetic app does too. Zwift won’t let me get over 100w ever. Also, my speed degrades after a few minutes and I can go all out and be doing 1mph. What’s the deal? I’ve rebooted my phone and trainer multiple times. I recalibrated using kinetic app and then force closed it.

1 Like

I’m having the same issue with Zwift on an Android phone and Kinetic R1 trainer. Has only worked correctly like 2 times since buying.

@Kris_Kilton and @Jim_ALLEN welcome to Zwift forums.
Are you trying to connect the controllable trainer via Bluetooth, or ANT+?

ANT+ support in Android is still in beta due to the complexity of the Android hardware ecosystem, so
the Android version of the game app does not support controllable trainers over ANT+ yet. It’s coming. Please bookmark this thread, where we’ve been announcing other types of sensor support over ANT+.

1 Like

Thanks. I’ll give it a try.

Nope, that didn’t work. Rebooted phone and trainer.

Hi - as I indicated in my post, I am connecting to Zwift on an Android phone using Bluetooth. I’m not using companion or any other toold.

@Kris_Kilton and @Jim_ALLEN

A little clarification, please. Since the subject line is “Android app not controlling my trainer,” I’m assuming you’re both expecting this function to work over ANT+?

Trainer control does not work yet in the Android app over ANT+. It’s something we’re working on, but it is not supported as of today.

If you’re asking about a different thing not working, please clarify.

3 posts were split to a new topic: Resistance locked on Kurt Kinetic Rock and Roll

I turned off ant+ and got the same results, the app doesn’t control my trainer. I tried the PC app and that works fine but not ideal.

A post was split to a new topic: Android app not controling the Tacx Vortex

A post was split to a new topic: Android app not controlling the Elite Zumo

Hi Kris,
Sorry to hear this. Could you email us at with your details?
They can help get to the bottom of this. Thank you for bringing it to our attention.

Kurt trainer users on this thread: we’re digging into this issue. Thank you for your patience.

I have the ANT show up on my app screen when pairing my smarttrainer. But it’s not yet supported? Can you tell me what the work around for this would be? Will it link up with a Cadence sensor attached to my bike? I really don’t want to have to hook up my PC. Thanks!

We need more details from you:
What trainer do you have?
Which brand / model of sensors (speed / cadence / two-in-one cadence+speed) do you have? Do these broadcast in ANT+ only, Bluetooth only, or both?
What brand / model of Android device?

@Kris_Kilton @Jim_ALLEN and others who have the Kinetic R1:
Our Android devs have been able to reproduce the unresponsive SIM/ERG issue specifically with the R1 Direct Drive (wheel-off) trainer and are working on a fix. Thank you for alerting us.

Kurt Kinetic wheel-on trainers should work on Android, as should other brands of trainers reported in this thread. I will split your questions into a different thread so we don’t confuse those following along.

1 Like

Update 2/14/20: 46128 has the Kinetic R1 sim/erg fix.

HI Nick, the latest release 46128. has the fix

Hi Kris, just to follow up - release on 2/14/2020 had a fix for the Kinetic R1 trainer. It was a general FTMS fix, so other trainers (not all) that had sim/erg problems over FTMS, are likely also fixed.
Thanks again for patience, and for riding Zwift Android.

I was not able to use my very expensive r1 trainer so I gave up/lost my patience and bought an Apple tv. That sucked having to buy another gadget to use this app.

1 Like