Android App - Feedback


(Jeff Abbott) #1

I used the Android App this morning for my 75min ride. It seems to work fine. I logged into Zwift on my computer then on the app. It showed me who was riding. Then when I started to ride, it switched over to the Ride mode. The Dashboard was showing correctly and updating every 2-3secs. The other screens with the buttons and rider list worked as expected.
I set my phone down and rode for a while. Only once out of the 4 times did the app lose connection and would have to back out of it and re enter the app.
Phone: Nexus 5 running Lollipop 5.0.1


(Brian Hill) #2

Can other Zwifters get in on the Android action? I’m an android user as well (Samsung Galaxy s4) - android 4.4.2


(Jeff Doughty PVC WBR (B)) #3

Just went on the Android Play Store. It is there for anyone to download I did and logged in. It was simple.


(Daniele Hohol) #4

I wish I shared your experience - after 10 minutes of riding, my Android app was still in the observer mode(showing me who’s riding). It actually crashed twice while I was pressing the settings button and pressing refresh.

I wish I had logs to show what happened…


(Richard Grieve) #5

I’m on Samsung Galaxy S3. The last time I used it, it crashed several times - while in ride mode, it switched to observer mode and stayed there. To re-enter ride mode, I had to force-stop the app, and restart. After doing this 3 times I gave up.

I’m pretty sure I had used it before, for a full/long ride, without the crashing.


(Jared Skolnick [GFNY]) #6

I just downloaded to a Moto Droid Pro and got nothing but observer mode. I tried tapping all over the screen, but nothing was a link. And no menu for options that I could find. Bummer.


(Jason Love) #7

Android App worked great with Samsung Galaxy 4. Easy to install and worked as expected except when exiting upon asking to save + strava the laptop still required save + strava to exit. Very nice addition to the ride and much easier to mount to bike for controlling aspects of the ride.


(Jared Skolnick [GFNY]) #8

I mistakenly said “Droid Pro” earlier - I meant Moto Droid Turbo. I’ve also added it to me Galaxy S3 (in-home WiFi only) and Galaxy Tab 3 and can’t get out of preview mode on any of them. This must be an issue with my WiFi config since all three are on the same WiFi as the laptop running Zwift. Any ideas?


(Brian Hill) #9

Jared… silly question, but are you logged into zwift on your pc and riding when you try to launch the app?


(Jared Skolnick [GFNY]) #10

Hi Brian. Not a silly question, but yes. I even tried clearing the app data, uninstalling it and reinstalling it while on a ride to make sure. As noted, since this is happening on three devices, it must have something to do with my WiFi configuration. I’m hoping a Zwift rep can comment - perhaps it uses an unusual port and I have it blocked or something.


(Jeff Doughty PVC WBR (B)) #11

I have the same issue. Works fine using my neighbors public wifi. Will not work on mine. My friend who own a computer networking company tried everything. Said he sees this kind of thing with combo modem/routers from time to time. Mine is a net gear combo using TWC isp.