Allow password autofill in companion's login form


(Vitaly Lysenkov) #1

Even with “Remember me” checkbox ticked I often get logged out on my companion app (Android). My phone suggests me to autofill the password from the Android’s password database and it succeeds inserting the needed data. But after a fraction of second the password disappears. It doesn’t happen so when I copy and paste my password manually.
Please fix this!
Thanks in advance!


(David K) #2

Zwift’s launcher and login screen both use Safari on Mac. If Zwift isn’t offering to save your passwords and won’t automatically log you into your account even when “Remember Me” is selected on login, it usually means there’s something wrong with Safari; specifically the way it saves or recalls cookies and cache. If you’ve disabled password saving in Safari, that may also cause the issue.

You may want to try resetting Safari back to installation defaults by following the instructions in the below article.
https://www.lifewire.com/restoring-safari-default-settings-446560

Ride On!


(Vitaly Lysenkov) #3

Hi David,

Thanks for getting back to this question!

As I mentioned in the original post, my issue is about Zwift Companion Android app, not the main Mac app.

Vitaly.


(David K) #4

My apologies, Vitaly.

I actually just came across a second ticket from a member with the same concern running Companion from an iPad 5. From what I understand, both Zwift and Zwift Companion use KeyChain to remember credentials. Here’s a few steps for clearing your Zwift cache and resetting your KeyChain feature.

You may be able to fix the login issue by clearing your app cache, force closing the app, or resetting your Keychain.

Force close Zwift between sessions
Before you launch the Zwift app and start a new ride, force close any existing Zwift sessions.
https://support.apple.com/en-us/HT201330
Old data can cause this issue - and it’s just a good practice - so swipe away any old session, then try again.

Clear your Zwift app cache
If the issue still occurs after force closing any old sessions, we recommend clearing the app cache. While there’s some third-party apps you can use to clear just the Zwift app cache, you can also just uninstall and reinstall the app to clear this data, so we recommend the latter.

Before doing so, you may want to backup any custom workouts and screenshots you have saved on your device.
https://support.zwift.com/hc/en-us/articles/208467596-Using-Workout-Mode
After clearing the cache/reinstalling, try again.

Resetting your Keychain
If neither of the methods above solve this, we’d like you to try resetting your Keychain. While we haven’t made any changes that should affect the log in process, we suspect there may have been updates from Apple that changed this. Here’s an excerpt from an Apple support article for any iPhone, iPad, or iPod touch with iOS 8 or later.
https://support.apple.com/en-us/HT203783

  1. If you have iOS 10.3 or later, tap Settings > [your name] > iCloud > Keychain > Advanced. For iOS 10.2 or earlier, tap Settings > iCloud > Keychain > Advanced.
  2. Tap Approve with Security Code.
  3. When asked to enter your iCloud Security Code, tap Forgot Code.
  4. Tap Reset iCloud Keychain to replace your iCloud Keychain in the cloud with the iCloud Keychain items on your device.
  5. Tap Reset to confirm. You’ll be asked to create a new iCloud Security Code.

Give each of those a try, and let me know how it goes!


(Vitaly Lysenkov) #5

Hi David,

Thanks again for getting back, I appreciate your help!

Unfortunately I can’t follow your advices because, as I said earlier, this ticket is about Android app (and not iOS or Mac).

I’ve captured a short video for you https://youtu.be/TKdLXDVNuwQ , hope it helps with understanding what this issue is about.

Vitaly