4-second lag between terrain and trainer

(Stephane Louvet Race3R) #41

Peter,

I’m also using a front panel USB3 port. I tried once to plug at the back of my computer in a USB2. The lag issue was still there. :-/

0 Likes

(Stephane Louvet Race3R) #42

Tacx didn’t gave me the changelog of the different firmware.
The support told me we could do a “response time” test. I replied I was read and really interested but 'm still waiting for their instructions.

0 Likes

(Stephane Louvet Race3R) #43

Hi every one !

I just installed a Rotor Inpower and declared it as the “Power source” in Zwift.
The cadence remaining the Tacx, such as the “controllable trainer”.
IT WORKS !

I’ll do a race tomorrow evening to really confirm.

0 Likes

(Stephane Louvet Race3R) #44

Update.

I did a 160km WBR 3.0W/Kg yesterday with this setup :

  • Power source : Rotor InPower
  • ANT+ HRM belt  : Decathlon geonaute
  • Cadence sensor : Tacx Vortex T2180
  • Controlable trainer : Tacx Vortex T2180

It worked nicely during all the ride !

I have more and more the feeling it’s more a Tacx issue now.
Their “power estimation algorithm” is maybe waiting too long to have a better accuracy at the cost of this huge unresponsiveness.
But as some Bkool pro or Kickr users report the same, I’m still in doubt.

And the other hand, my Zwift ticket have been transmitted to the 2nd level analysts.
I’ve sent them my log files and I’m available for tests.
I told them it’s on their interest to works together with Tacx to resolve this issue as they are unsatisfied customers stopping their subscription.

Next test for me, I’ll borrow another Tacx Unit and see if the problem is the same. A friend of mine have the same Vortex but with an older (factory) firmware.
I really hope this will be the last test !

Stay tuned 

0 Likes

(Kevin West) #45

I have this issue too - bunch riding is hard - yoyoing all over the place.

I hadn’t bothered trying to change the power source from my tacx vortex to my stages power meter because, like others have said, the reported power output on the top left does seem to update in an acceptable timeframe (1-2sec), it’s just that my avatar takes another 4-5sec to respond.

I think my issue is my 7 year old laptop though - interesting that others with proper gaming rigs are still having issues.

i’ll try using my stages as the power source and see how I go - although it will take some will power to not “left leg only” when I’m trying to bridge a gap…

0 Likes

(Stephane Louvet Race3R) #46

Kevin,

I’m interested to know the result of this change :slight_smile:
You can also maybe use your Stage as the cadence sensor as well (The Rotor propose it). It’s much more responsive than the Tacx estimation.
As I do track cycling, I’m used to pedaling “round” and I can fool the Tacx algorithm by doing a round pedal stroke.

I look forward to read you.

0 Likes

(Stephane Louvet Race3R) #47

OK. So borrowed a friend’s vortex.
The iphone app tells me the firmware is 3.1.9 / 0.2.7
The latest being 3.1.22 / 0.4.1
The “what’s new” section tells :

  • improved upgrade proces
  • improved peak power and calibration

So, thanks, I won’t upgrade.

I changed only the Vortex in may setup, everything else is the same.

The lag is gone.
It’s still not perfect perfect, instant response is not possible, but the lag is now around 2 seconds. I didn’t miss my A race start and drafting is much easier.

TACX ? what are you doing ? 

0 Likes

(Stephane Louvet Race3R) #48

On the watts, compared to a Rotor InPower.
The vortex gives a bit less when I’m under 200W and a bit more when I’m above 240W
But still in the +/- 10%, even less.

0 Likes

(Roman Troyanov [Velo+]) #49

Hi zwifters! Tomorrow I unpair my Tacx Vortex trainer from Atn+ and pair it using bluetooth via Zwift mobile link app and Whoala! No delay at all. Resistance changes instantly independent of terrain. I hope it will be useful for you.

0 Likes

(Stephane Louvet Race3R) #50

Hello Roman !
I’m happy it works for you :slight_smile: (my advice is still to not flash your Vortex)

I already tried the mobile link without noticing a big improvement.
I’ll give it another chance this weekend, the app received a major update recently ! :slight_smile:

Ride On !

0 Likes

(Curt Knight) #51

I have also been having this lag time issue. Strangely, I didn’t seem to have it until a week or two ago, but after doing a training session in ERG mode, my regular rides haven’t been right. Setting the ride resistance to 50% gave me almost no hill effect–even made some uphills easier! Setting to 100% resulted in very sudden hill onset resistance that nearly stopped me, and carried on past the hill peak for a few seconds.

So, based on another Zwifter’s response in this thread, I moved my Ant+ device out of my laptop’s USB port and used a USB extension cable to locate it close (<6 inches) to my Tacx Bushido. Following that, the ride was very good with response and effect just as expected. I don’t know for sure that was the cure, nor why it would have worked without the extension cable before, only that it was excellent after that change yesterday!

Equipment:
   Power/Speed/Cadence - Quarq Riken
   Smart Trainer: Tacx Bushido

 

0 Likes

(Igor Tatarinov (A-)) #52

As others have mentioned switching from ANT+ to Bluetooth greatly reduces the lag. Even if you use MobileLink with your phone. I have a MacBook and can connect directly. Zwift doesn’t support Bluetooth on PCs.

The best place to test the lag is the London escalator. I still see a log but it’s more like 1-2 secs rather than 3-4 seconds I got with ANT.

0 Likes