4-second lag between terrain and trainer

(Tyler Michael) #21

They are blowing smoke up your ass by blaming your ping to their servers.

0 Likes

(Lloyd Rees) #22

The other element is the trainer response time…

 

0 Likes

(Todd Taylor) #23

I’m having the same issue running Windows 10 on my PC and a first generation Wahoo Kickr.   It obviously doesn’t matter when riding by myself, but I really like doing group rides and then it’s noticeable.  I thought maybe it was my Kickr, but apparently the issue isn’t any specific to any particular smart trainer.   I live in Wisconsin, so I’m only 2 time zones away from servers on the West Coast.

What I find odd is that why does it seem like the rest of the group of riders all seem to  not have lag, except me?  Am I just lucky? :slight_smile:

 

0 Likes

(Todd Taylor) #24

In another thread, a Zwift users claims that switching from an off brand ANT+ USB dongle to a Garmin dongle removed the lag time he was seeing.  I currently have a Suunto ANT+ dongle and just ordered a Garmin dongle on eBay for $20.  I’ll report back if it makes any difference.

0 Likes

(Todd Taylor) #25

I got the Garmin ANT+ dongle and a USB extension cord to try and fix this delay issue.  I also changed my default Zwift settings:

  • Changed Power Display to “Instant”
  • Changed Trainer Difficulty to “Max” (was previously at 50%)

I can’t say that the Garmin dongle is better than the Suunto, but mounting the dongle just inches away from the sending unit on my Wahoo Kickr (right near where the rear hub of my bike would normally be) made a big difference in terms of how quickly Zwift sense my Kickr, heart rate monitor, and cadence sensor… there’s almost no lag.  I find that interesting since my laptop is sitting right next to my bike, but moving the dongle even closer made a noticeable difference.

The changes to the Zwift settings also made my rides seem more “real-life like”… hills seem as hard as they should be :wink:

However, none of these changes seemed to get rid of the “lag” I experienced on hills in group rides or races.   I’m inclined to think the problem might not be me or my equipment, but the people I’m riding with?  I’m speculating that most riders grind big gears and when they hit a hill, they lose a lot of speed… at which point I typically rocket right past them as I spin away.   Then at the top of the hill, the other riders finally gain momentum and then blast past me as I don’t typically sprint over the top of a hill.

Anyway, hopefully my findings were useful to someone!

1 Like

(Baris O.) #26

Hi,

I have a bkool pro, using an ant+ dongle with a Windows 10 PC with sufficient GPU power and a 100mbit/s internet connection. I experience the same delay, and I’m pretty sure it’s not related with the trainer at all. I see the power output is updated almost instantly (even with the display 3 sec average setting) but my avatar reacts to my actions in 4-5 seconds as well as the resistance changes. It’s a shame for this problem to last for this long, even though almost everyone has this issue.

 Edit:  I can confirm that there is no delay (or less than 1 seconds to be fair) with Bkool simulator. The terrain changes and user actions almost instantly adapt to the game. SO I DECIDED TO SUBSCRIBE TO BKOOL UNTIL ZWIFT RESOLVES THIS ISSUE.

Edit: Zwift says the unresponsiveness is due to losses with ANT+ connection drops. But still the power is updated successfully throughout the ride, on both my Edge 520 and the Zwift simulator almost instantly.

Thanks.

 

 

 

0 Likes

(Tyler Michael) #27

Good choice, Baris. I dropped Zwift subscription as well. It speaks volumes that Zwift won’t even acknowledge this thread.

0 Likes

(Nigel ) #28

Here’s what I don’t get. You can ride Zwift not connected to the internet so long as you start off being connected then at the end if you want your ride saved you connect back up. I do this sometimes when working away from home and the motel gives me limited amount data usage. Zwift works fine but don’t get any other riders. Why then does it still lag. Ok, so they’ll say it’s the Trainer’s fault. Please Zwift, work with the Trainer manufacturers to resolve this problem and or add in a lag control slider where the user can specify how far ahead to read the terrain changes.

Strange that my hammer trainer responds straight away to power target changes when I use it with Trainerroad (ERG mode)

0 Likes

(Baris O.) #29

I opened a case and Zwift Support wants me to send some data to investigate the problem, I’ll let you know the output of the case.

0 Likes

(Todd Taylor) #30

Another update…

I decided to try my newer laptop today instead of the 5 year old laptop I was previously using and it made a huge difference.  Even though my old laptop had tons of RAM, SSD drives, and an i7 processor, the graphics card is likely the problem.  

In tonight’s group ride using the newer laptop, not only were the graphics much smoother all around, but the annoying lag I was experiencing has been greatly reduced.  I’m not saying everyone should go out and buy a new computer as clearly that’s not the problem for some of you, but if you’re trying to use an older PC on Zwift, well, good luck! :slight_smile:

0 Likes

(Stephane Louvet Race3R) #31

I’ve got exactly the same problem you describe.
My setup is Tacx Vortex 2180 with a Tacx USB antenna.
My PC computer is powerfull enough to paly the lastest video games.

I’m always missing the start of the races because of this lag !
I push as crazy, reach 500W and I can only see the others going away from me !
This is super annoying and in A races, forget it, you won’t catch up the pack anymore …

I upgraded my Tacx Vortex firmware recently but my girlfriend have also one with an older firmware. I’ll try to swicht and see if it’s a Tacx intell program issue.
She also have a Zwift ANT+ USB dongle, i’ll try this as well.

I will also try again Bkool, the track simulator was awesome real.
The difference in power while drafting / leading is really well made and is instantaneous. If Bkool can make it, then it’s a zwift problem.

 

 

0 Likes

(Peter Harris (ODZ)) #32

Hi Stephane,

I would love to know how you get on.  Todd Taylor said he swapped his PC for a better graphics card but my PC can handle the latest games in 1440P (4Gb graphics card) no probs, so I dont believe its a PC issue in my case.

I have cancelled my Zwift subscription because of this and Ive not been on it for a few months.  Its a shame they cant be bothered to sort this out.  

I am using a TacX Vortex with a Garmin ANT+

It lag has always been a bit bad but it used to be workable and I enjoyed zwift. I had learnt how to use the lag to stay in the pack etc., but then a zwift update happened and after that I find it impossible to stay in the pack.  I speed up to catch the group, slow down to their pace once caught but then I speed past them to way out in front, I then stop pedalling so they can catch, try and time the pedalling again to join the group as they close in, but then they speed past, and the horrible cycle repeats.  Forget drafting, its now virtually impossible.

0 Likes

(Stephane Louvet Race3R) #33

Exactly the same. I struggle to stabilize and match a group pace.
The trick I’ve found now is to not look at the “video” but I look at the other riders w/kg and then adjust my pedaling accordingly.
But then I have a problem when there is an attack or a sprint. Even if I react right away, my avatar on the screen is not ! So frustrating :-/

And yes, I also have the feeling this changed with one of the last zwift update.

I’ll try Bkool this evening and let you know how it is going with this software.

0 Likes

(Stephane Louvet Race3R) #34

I tried a bit Bkool yesterday evening.

I did a short velodrome ride and a 3D virtual ride.
It’s not day and night but it’s a bit more responsive than Zwift.

Still, jumping out of the saddle and sprinting, the wattage and smart trainer resistance is too slow to change compare to what is was last november when I brought this equipment.

I now suspect more the Tacx Vortex firmware. :confused:
I’ll try to swap mine with a friend of mine who as the same unit but with an earlier firmware.

I might try the Tacx software this evening and see what’s going on.

0 Likes

(Peter Harris (ODZ)) #35

Hi Stephane, thanks for continuing to look into this.  I have no idea what version my Tacx Vortex is.  I tried to check via the app on my phone but it doesnt tell me the version of the unit, it only tells me the version of the app, which is not a lot of help.

If you find out anything else, then please let is know.

Cheers.

 

 

0 Likes

(Stephane Louvet Race3R) #36

I also contacted the Tacx support to know if they can give more details about the firmware changes.
Because “Better power estimation.” in the small changelog, this is just marketing to me.

I really would like to solve this problem as it is so frustrating to race in zwift now  :/

0 Likes

(Peter Harris (ODZ)) #37

Stephane - thats a great idea and certainly wont hurt however people with Wahoo Kickr are also reporting issues.

See this other thread on Zwift forum…

https://support.zwift.com/hc/en-us/community/posts/204207896-4-5-second-delay-on-Bkool-Pro-?page=1#comments

Im still interested to see what TACX say to you though…if anything.

0 Likes

( Drew E. [HBCC]) #38

Thanks everyone for posting here. I thought I must be hallucinating. I mostly use TR where I don’t experience this issue, but just started with Zwift Academy last night. As others have expressed, there is a very noticeable lag between laying down the watts, and having the avatar respond on the screen. The result is a yo-yo effect of accelerations and decelerations to stay with the leader beacon. Very frustrating.

In case there is any question, I’m using a two month old MSI Raider-001 gaming notebook with a 1070 Nvidia card and i7 7700K. CPU and GPU are not factors.

My internet is FiOS gigabit, with 940Mb/sec download and 880Mb/sec upload. Ping is not a factor. Throw that argument in the trash.

I have two Tacx Neo smart trainers and both exhibit the same problem with Zwift, but not with Trainer Road.

I am also using the Tacx Upgrade smart ANT+ antenna that is shelved on the empty rear brake caliper, approximately 6 inches above the trainer.

The problem, very plainly, is Zwift. Anything else you hear is a lie.

0 Likes

(Peter Harris (ODZ)) #39

Hi Drew / Stephane.

I actually cancelled my Zwift subscription early in the year because of this problem, but people replying on this thread got me interested again so I signed up for a month with a view to trying it out and trying to help others by testing etc.

There was an update when I loading the zwift program on my PC, which is not a surprise as I hadn’t used it for months and months.

I logged in and rode around and it was difficult to tell whether it was fixed or not as I was riding alone.  So on Saturday I entered a race and there was 3 of us in a little group and we seemed to keep together with no issues.  No yo-yo-ing of acceleration and deceleration.  It seemed to me to be like how it used to be when I first used zwift i.e. a minor delay but it was definitely workable and I just adapted to it to keep in the group.  Before I quit Zwift, there was no adapting, it was almost impossible to stay in the peleton.  I will do more races and let you guys know how its going in case it was a one-off…I hope it wasnt.

So the only difference is a Zwift update which I suspect you guys have already had anyway, but the other thing is that in the time between my leaving Zwift and coming back, my USB 3 port on the front of my PC broke.  I am now using a USB 2 port.  Is this the difference???!!  Who knows. 

If you are using USB 3, try USB 2 instead and see if its any better.  It may be a red herring but I have nothing else to go on as to why its now much better.  Kind of makes sense though if the Garmin and ANT+ dongles arent USB 3 compatible?  Worth a try.  Or it was the software update (rolls eyes)…

Cheers

0 Likes

(Stephane Louvet Race3R) #40

I’ve found a Shane Miller video showing a power lag issue on a Tacx Flux.
Tacx have been able to reduce the delay from 10s to 5s for the “estimated” power just with a firmware update.
https://youtu.be/IjvyH3TEDNo?t=9m41s

I haven’t done all the tests I wanted so far (test a recent USB/ANT+ dongle). but I’m my almost sure Tacx have a role also in this issue.

My test this eve : I borrow Rotor Inpower from a friend.  I install it and use it in zwift and see. So the power measurement should  be instanteous !

0 Likes