2016 Elite Turbo Muin Smart B+ doesnt work :(


(Alex Hammer) #1

Extremely high watt Display! The new Elite Turbo Muin Smart B+ (>30000) is not supported.


(Neil Barnes PACK) #2

It definitely is. I purchased the same trainer yesterday. Set Zwift up this morning with no issue whatsoever. 

Did you set the Misuro B+ to 12 blinks? 


(Chris Zach) #3

That was my Mistake !


(Neil Barnes PACK) #4

:slight_smile:


(Darren Johnson) #5

I’m having similar issues only it recognizes everything just my power and speed are zero.

yes i’m using a usb extender etc etc as per the knowledge base and the 2 support tickets i’ve raised where the zwift staff just copy what is quoted in the knowledge base

 


(paulo santos) #6

i am having some troubles aswell. all is set properly. 12 clicks on the misuro b. usb extender and all. i start riding before logging in zwift to activate, and when it s time to pair, i see my HB belt, my speed and cadence sensor from garmin.(that i usually select) the zpower recognize the sensor and as for the controlable trainer nothing appears. so i cant change the dificuty to 100% ingame or the “ERG” when available.

What can i do?


(Neil Barnes PACK) #7

Nothing I’m afraid.

The turbo Muin Smart B+ is not a controllable trainer even though it pairs as one. 


(Darren Johnson) #8

I have the turbomuin  wth the misurio b+ sensor.

The only way to get it working is as I describe here.

https://support.zwift.com/hc/en-us/community/posts/204460853-Elite-Turbo-Muin-and-Elite-Misurio-B-How-I-got-it-working-after-a-month-of-stress


(Nicolas Pignier) #9

where can I set the “trainer difficulty” ? I don’t see this option in any menu !


(Darren Johnson) #10

Mine is a basic turbomuin and had to buy the Misurio B+ separate, in the instructions it says you open up the sensor and press the internal switch until the internal led flashes 12 times.