2 minutes into my ride my cyclist on the screen stopped cycling with no statistics being recorded

Two minutes into my ride today my cyclist on the screen stopped cycling. My Kinetic ap says I am connected, however when I go to calibrate my MPH, it does not show me moving, and thus 0.0 MPH. I have tried to disconnect the power and start again, but no luck. Firmware is up to date with the lastest software. Has anyone had this happen before? Any solutions?

Hi, Jeff.
Not clear about the whole issue. What is your trainer model?
2 minutes into the ride? Which ride? Is it into the ride inside Zwift or inside Kinetic ap?
If inside Zwift, your Kinetic ap should not be connected in the same time: in this case it is normal that you have no data inside Zwift, since your sensor is connected and transferring data to Kinetic ap.
I would do the following:

  1. Disconnect all the devices from your Kinetic sensor.
  2. Open Kinetic ap and find the sensor (you should pedal for a minute in order to activate it). If the sensor connected correctly inside Kinetic ap, I would ride 10 minutes warm-up training and after those 10 mins would calibrate it. After the successful calibration I would close the Kinetic ap and only after successful closure would open Zwift.
    In case if you unable to connect correctly the Kinetic sensor inside Kinetic ap, try to take out the battery and than place it back (or try to check and replace it) from the Kinetic sensor (which one do you have? Is is the latest one InRide3 sensor - the green one?).

Thanks. I am trying to ride within a Zwift app program (FTP Builder). Not within the Kinetic app. Ugh! The last time the cadence didn’t record MPH, it was a motor issue and Kinetic had to send me out a new one.

I can see that you already had a similar topic several months ago: My bike is not moving in the Zwift app on my iPhone 8 app
Is this the same issue that was never solved since January?
Could you please elaborate about your trainer type, sensor type, PC/MAC/cell/tablet, are you connected with a usb Ant+ dongle or a Bluetooth connection etc?

It’s a similar issue I guess. I own a New Road Machine - Control smart trainer. I am using a cell phone (iPhone 8). My desktop does not allow me to upgrade the graphics support so that is why I use my phone.I am connected via Bluetooth.

Ok. Did you tried to go with the step-by-step method in order to eliminate the case?
Step 1. Kinetic ap connection. Does it work with Kinetic ap only? Are you able to connect and then ride inside Kinetic ap and see your watts, speed, cadance?

I was reviewing my last post in Dec and this is not the same problem as my wattage is accurate when it’s working. Back in January when Kinetic sent me a new motor it was because the cyclist did not move on the screen and the cadence did not work. When I called up Kinetic they said it was a motor issue…at that time.

Are you with Zwift?

If the Step 1 during a simple warm-up training inside Kinetic ap would work correctly, only then in this case I would go to Step 2.
Step 2 close Kinetic ap and try to connect to Zwift, then inside settings find your trainer.
Also, I would test any other device (tablet, PC, Mac - even if there is a PC with low spec. video card, still you could install Zwift and go to settings and see if it could find your trainer)

No. I’am just a user as you. Just trying to help you )
But you could always go and open a ticket with Zwift tech support!

OK. Thanks so much for your help

Yes, I already opened a ticket with Zwift Support and Kinetic Support. Thank you.


And when outside of the FTP test, are you able to ride correctly with power, cadence and speed data?
Is it only inside FTP test?