1 dropped ride w/ incomplete save and 2nd ride finished but incomplete save

For the past two days I have been unable to completely save my group rides. I use a Macbook pro with latest IOS update to run the game and I use the ZC app on my iphone while riding since the computer sits connected to the TV. For yesterday’s ride, I was in midst of group ride and everyone dropped off the screen. My ZC app on my iphone reverted to the home screen rather than in ride screen. I tried to save the ride on my computer and the error message said that I had no internet connection. The problem is that I did have strong internet connection showing on my computer. Today’s ride was completed but as I was continuing to ride the same thing happened: ZC app on iphone dropped out to home screen. I tried to save the ride on the computer but same error message. Again I was showing that i had a normal internet connection to the computer. My computer sits right next to the wifi router. The internet service is fiber optic and high speed. One thing that may be causing problem is I was connecting to the ZC on phone via built in blue tooth option rather than connecting via ZC app. I have just changed this now and will see if issue resolves
Both rides show up in my activity feed but without title and without the usual information.
My system: Macbook pro (2014, Big Sur OS), Saris M2 trainer. Ant+ connection powermeter/cadence/HR. I connect my computer to the TV directly and BT music to the TV speaker.